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Making a guitar body 
The purpose of this first section is to make the body of a guitar in 
order to review some of the functions addressed during the first 
training cycle. 

Concepts addressed: 

- Sketch: Line, arc, sketch copy, dimension and constraint 
- Extrusion 
- Wood machinings: Pockets, drillings and mouldings 
- Data structure: Part and set definition 

Creating the body 

Start the sketch 

 Create a new document of the  Design type. 
In the Advanced parameters, select Without template. Select the Associative design 
mode and then Millimeters. 

 Click on OK to confirm. 

 Activate the Sketch context , then start a new sketch.  

 Draw a first line 1 as shown opposite.  

 Apply a coincidence constraint of this line to the Y axis.  >  

 Dimension this line with a nominal value of 80mm.  

 After applying the value, activate the Symmetry constraint option in the dialog bar, then 
select X as the symmetry axis.  

  

 
Note: Applying a symmetry constraint to a dimension allows the dimension to be 
automatically centered on the selected axis, regardless of its length. 
 

 Start the Circle function  in Passing point mode to draw the two circle arcs 2 and 3 

as shown below.   

 Draw the line 4 after the circle arc 3 as shown below. 
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 Dimension the points between 2 and 3, as well as 
the two points of line 4 with the values shown 
opposite. 

 Apply a tangency constraint between 1 and 2 and 
between 2 and 3. 

 
Note: All the sketch elements are green, which means 
that the sketch is totally constrained. 
 
 
 
 
 
 
 

 Draw 4 circle arcs (5, 6, 7 and 8) in Passing point mode as shown below. 

 Then dimension the different points with the given values. 

 Apply tangency constraints between the arcs 4 and 5, 5 and 6, 6 and 7 and 7 and 8. 

 
Copy the sketch 

 Start the Copy function.  

 Using the selection (lasso) , select 
segments 2, 3, 4, 5, 6, 7 and 8. 

  

 Click on OK to confirm. 

 In Propagation, select Simple mirror in 
the dropdown list. 

 
 
 

 Select the ZX plane as the symmetry plane 

in the dialog bar.  
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 Dimension the different points of the 
copied elements. 
Do not change the values of these 
dimensions. 

 Then apply a tangency constraint 
between 1 and 2’. 

 
 
 
 
 
 
 
 
 
 
 
 

 
 

 Use the Modify parameter function to change the dimension values of the 

points of arcs 7’ and 8’ as shown opposite.  
 
 
 
 
 
 
 
 
 
 
 
 

Close the sketch 

 Draw two lines 9 and 10 between the arcs 8 and 8’ as shown 
opposite. 

 

 Apply: 

- an orientation constraint along X to the line 9; 
- a perpendicularity constraint between lines 9 and 10; 
- fillets with a radius = 5mm between 8’/9, 9/10 and 10/8. 

  
 

 End the sketch. 
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Extrude the body 

 From the Shapes context, start the Extruded 

function.  

 Select the previously drawn sketch in Section 
curves or texts. 

 Extrude the body to a height of 35mm. 

  
 

 Save this document: 

- Answer No to the request for a part definition. 
- Create a new folder called Guitar body and rename the file Guitar body. 

Performing the operations 

Make the pockets 

 Make layer 1 current.  

 Start a new sketch, then use Contour > Rectangular.  

 Draw a rectangle as shown opposite and select Auto 

dimension  to automatically place 
the dimensions of the rectangle.  

 

 Use the Modify parameter function to change the values to 73mm on the X 
axis and to 53mm on the Y axis. 

 Apply two coincidence constraints: 

- between the segment 1 of the rectangle and the edge 3 of the guitar; 
- between the segment 2 of the rectangle and the edge 4 of the guitar. 

 Apply a fillet with a radius = 5mm on the left-hand angles of rectangle 1. 

  
 

 Draw two new rectangular contours in Constraints = Perpendicularity mode. 

  

 Select Auto dimension to place the dimensions of the rectangles. 

 Use Modify parameter  to change the dimensions of the rectangles:  

- 15mm on X and 60mm on Y for rectangle 2; 
- 18mm on X and 70mm on Y for rectangle 3. 
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 Use the Modify element function on the vertical dimensions of the rectangles (60 and 70mm) to apply a 
constraint to the X axis. 

 Dimension: 

- the distance between rectangles 1 and 2 to 20mm; 
- the angle between the left-hand side of rectangle 3 and the X axis of the coordinate system to 105°; 
- the distance between the left-hand side of rectangle 2 and the bottom right point of rectangle 3 to 

100mm. 

 

 Apply fillets with a radius = 7mm on the angles of rectangles 2 and 3. 

  

 

 End the sketch. 

 In the Wood context, start the Pocket function.  

 Select the top of the guitar body as the reference face. 

 Set Generatrix = Hidden and Generatrix sketch = Global. 

 

Note: Generatrix = Hidden is used to hide the current sketch once the pocket is performed. 
Generatrix sketch = Global generates a pocket for each contour of the sketch in one single operation. This means 
that all the pockets will have the same characteristics. 
 

 In Curve(s), select the sketch.  

The Pocket parameters window opens. 

 Set: 

- Through: No.  
- Depth: 15mm. 

 

 Confirm the window with OK to make the pockets. 
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Make the drillings 

 Start the Drilling function.  

 Set Coordinate system = Constraint, Mode = Dynamic and Hook = Current coordinate system. 

  
 
Note: The Dynamic mode allows a drilling to be positioned and dimensioned at the same time. 
Hook = Current coordinate system is used to place the drilling dimensions in relation to the current coordinate 
system. 
  

 Position the drilling on the top face of the guitar 
body at 85mm in the X+ direction and 87mm in 
the Y- direction. 

 
Note: The hooking of the drilling in dynamic mode is 
made based on the precision of the step defined in 
the grid. 
If the value of the dimension is not exact, it will be 
possible to modify it later using Modify parameter. 
 
 
 
 

 In the Drilling models window, select hole in Standard models, then set: 

- Hole: Through one 
- Diameter: 15mm 

 

 Once the drilling has been performed, select Propagate in the dialog bar.  
 

 Select Linear propagation in the X+ direction, set 
the distance per instance to 50mm and the total 
number to 2. 

   
 

 Then make a third drilling: 

- 185mm in the X+ direction and 87mm in the Y- 
direction 

- Hole 
- Through one, Diameter: 7mm 
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Make the moulding 

 Start the Moulding function.  

 Select Sweep = Planar face to perform a standard 
moulding on a planar face. 

 Select the top of the guitar body as the reference face. 

  

 Set Join edges = YES and Follow tangent edges = YES. 

 In Reference edge or curve for tool path, select the 
contour edge of the guitar as shown opposite. Click on 
Stop to confirm the selection. 

  

 Click on OK to confirm the default direction of the arrows. 

  
 
The Parameters window of the moulding opens. 

- In Standard TopSolid’Wood select Groove mill in the Mill category. 
- Set an entry and an exit with a radius = 0mm. 
- Set Parameters = Axis and Z dimension = 3mm. 

 Click on OK to perform the moulding.  

 Use Copy operation to perform the same moulding on the base of the guitar. 
 

 

              
 

Create the groove 

 Make layer 2 current.  

 

 Start a new sketch. 

 Draw a horizontal line in Axes (Z) = YES. 

  
 Apply an alignment constraint to this line with the X axis. 

 Apply two coincidence constraints:  

- of the left-hand point of the line on the left-hand 
pocket; 

- of the right-hand point of the line on the middle 
pocket. 

 Finish the sketch. 
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 Make a groove on the top face with the drawn line as the tool path and the guitar body as the shape to 
profile. 

 Select Stop. 

 In the Parameters window of the groove, set:  

- Tool type: Routers 
- Standard: TopSolid’Wood 
- Mill > Simple mill 
- Parameters : Centred 
- Gap distance: 0mm 
- Groove width: 5mm 
- Groove depth: 5mm   

 

 Click on OK to confirm the settings. 
 

 
 

Data definition 

Define the part 

 Use the Wood > Define > Define part function to define the guitar body: 

- Designation: Guitar body 
- Material: wood > mahogany 

 In the Cutting-up tab, add 30mm over dimensions in length 
and width. 

 
 
 
Note: It is possible with an option to view the stock of the part as shown below. Viewing the stock is helpful to 
validate it. However, it is not recommended to work with the stock displayed. 

 In the Part definition window, open the Stock tab. 

 Check Make stock and validate the window with OK. 

  

Note: If the stock is not centered on the part, check the 
boxes Both sides for the Over length and the Over width 
repartition in the Stock tab. 

 Start the Define part function. 

 Select the guitar (and not the stock of the guitar) as the 
part to define using the rotary selection. 

 Select Modify cutting-up. 

  

 In the Stock tab, uncheck Make stock. 

Define the set 

 Use Wood > Define > Define set > Characteristics > Modify cutting-up to define the set: 

- Designation: Guitar body 
- Main set: Single Unit 

 Save the document.  
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Introduction to the components 
When designing design projects, the user often or always needs to use production standards. These standards can 
be for example: 

- Hardware parts (screws, dowels, hinges, slides…) 
- Interior design components (cabinets, doors, shelves, separation panels…) 
- Complete furniture (coffee table, counter, door…) 

 
They allow information to be centralized and the component to be designed only once to help minimize the time 
it is used in projects. 
 
 

Creating a library 

 Create a new Design document. 

 Open the options using Tools > Options. 
 
 
 
 

 In Component > User library, add a user library using the Add button. 

  
 

 In the Name field, enter Training library. 

 Select C:\Projet as the path and create a new folder called Training library. 
 

  

 Click on Add to create this new library. 
 

  

 Click on OK to confirm the options. 
 
Note: In order to preserve you library components, it is not recommended that you modify and save the 
components of the TopSolid standard libraries (My 3D Standard, TopSolid’Wood, AFNOR…).  
To modify and use the standard library components, it is better to save them in your own libraries. 
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Exercise 1: Creating a shelf 
The goal of this exercise is to make the different parts of the shelf as constrained blocks, and then assemble them. 
This shelf will be saved in the library. 

Concepts addressed: 

- Parameters 
- Construction volume 
- Constrained blocks 
- Defining the parts and the set 
- Assembling the parts 
- Saving in the library 

Designing the construction volume 

Create the parameters 

 Create a new Design document . In the Advanced parameters, select Without template. 

 Use the Parameter > Create function to create the following four parameters in Unit type = Length mode. Do 
not display the texts of the parameters. 

- Value = 1200; Name: l; Designation: Shelf length 
- Value = 400; Name: d; Designation: Shelf depth 
- Value = 300; Name: h; Designation: Shelf height 
- Value = 19; Name: t; Designation: Panel thickness 
 

 >  

Create the construction volume 

 In the Shapes context , start the Block function , then enter X length = l, Y length =d and Z length = 
h. 

  
 

 Select the center of the absolute coordinate system as the alignment point. 

 Start the Attribute > Transparency function to apply a transparency of 7 to this block. 
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Creating the parts 

Low part 

 Make layer 1 current.  

 In the Wood  context, start the Constrained block function.  

 Set the t parameter as the thickness, then select: 

- the left-hand side of the construction block as the first plane. 

  

- the right-hand side of the construction block as the second plane or point.  

  

- the front face of the construction volume as the first plane. 
- the rear face of the construction volume as the second plane or point. 
- the bottom face of the construction volume as the positioning plane. 

 Adjust the positioning of the constrained block using the yellow arrows so as to place the part inside the 
construction volume. 

 

Top part 

 Create another constrained block to make the part below: 

- Thickness = t 
- First plane: Select the left-hand face of the construction volume. 
- Second plane: Set Mode = Faces, enter Second shift = (2/3)*l, then select the right-hand face of the 

construction volume. 

  
- First plane/Second plane: Select the front and rear faces of the construction volume. 
- Positioning plane: Select the top face of the construction volume. 
- Position the constrained block inside the construction volume. 
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Side part 

 Switch off layer 0. 

 Using the constrained block, make the part below: 

- The constrained block has a thickness = t. 
 

 

Defining the parts and the set 

Define the parts 

 Define the parts using Wood > Define > Define part. 

 For the three parts, set the material to wood > oak. 

 For the low part: 

- Designation: Bottom shelf top 
- Reference: BST 

 For the top part: 

- Designation: Top shelf top 
- Reference: TST 

 For the side part: 

- Designation: Shelf side 
- Reference: SS 
- The grain orientation of the part must be placed on the height. Use the Invert axes button in the Cutting-

up tab to rotate the cutting-up axes of the part. 

 

Note: In TopSolid’Wood, the length of a part always matches its grain orientation. 

Define the set 

 Use Wood > Define > Define set > Characteristics to define the set. 

- Designation: Wall shelf 
- Reference: WS 
- Main set: Sub-assembly 
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Assembling the shelf 

 In the Wood context, start the Dowel function.  

 Select Smooth pin in the Pin category and select the code 35x12. 

  
 In the dialog bar, select the Filter mode and set Propagation = YES. 

  
 Select: 

- the contact face between the side et the top 
as the support face. Use the rotary selection 
to select this face. 

 
 
 

- the front edge of the top as the start face or edge. 

- Centred automatically.  

Note: The Centred automatically option is used to automatically center the assembly in the thickness of the part. 

- the rear face of the top as the terminate face or edge. 
 

 In the Distribution definition window, select the Advanced mode. 

  
Note: The Advanced mode is used to provide minimum start and terminate distances for the dowels, as well as a 
step between the dowels. The quantity of dowels will be automatically calculated.  
 

 Then set the following parameters: 

- Step: 96mm 
- Minimum distance to start: 50mm 
- Minimum distance to terminate: 50mm 

 Confirm with OK to position the dowels. 

 Use Copy propagation, and then repeat the operation to assemble the 

side with the bottom shelf top.  
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Saving in the library 

Define the parameters as drivers 

Note: Defining parameters as drivers allows their values to be modified when inserting the component in an 
assembly file. 
 

 Start the Assembly > Define component > Define drivers function. 

 

 Enter the l parameter as the driving element to insert.  

  

 Press Enter to confirm. 

 Press Enter again to confirm the parameter designation. 

 Define the parameters d, h and t In the same way. 
 

Save the component in the library 

 Use Assembly > Define component > Edit/save template. 

 
 

 Select Save standard template. 

 

Note: Save standard template is used to save a file in the component library. 
Edit standard template is used to edit a file already saved in the library. 
 

 In the Standard dropdown list, select the library you created: Training Library. 

 Enter: 

- New family: Furniture 
- New type: Shelves 
- New variant: Wall shelf 

Note: Family, Type and Variant correspond to the different levels of the component library.  
 

  
 

 In the New version field, enter 00. 

Note: A new version of a component is done when a number of changes have been made to that component. 
This new component will be saved in a new file.  

Thus, the assemblies using the old version of the component are not modified and you can use the new version 
for the new assemblies. 
 

 Uncheck Supplier code and check Purge operations geometry.  

Note: The Purge operations geometry option improves the calculation performance of the components. 
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Note: Once the component has been saved in the library, $STD=LibraryName is shown before the file name in the 
software banner. 

   

Once the file has been saved in the library, click on the disk icon to save the changes made to the file.  

Supplement: Making the supports 

Create the shelf supports 

 Make layer 2 current. 

 Start a new sketch and draw two circles 20mm in 
diameter as shown opposite. 

 
 
 
 
 
 
 

 Use the Dimension function to dimension the 
center of the circle with the top shelf top edges 

to 50mm as shown opposite.  
 
 
 
 
 
 
 
 
 

 End the sketch, then extrude it in Generatrix sketch = Global and Result = One shape per profile modes. 

  

 Once the sketch selected, extrude it to a height = (h-2*t)+20 in Alignment = Centered and Type = Solid 
modes. 
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Define the supports 

 Using Wood > Define part, define the two supports previously created. 

 Select the cylinder of the support as the length axis and Y+ as the width axis. 

 Set: 

- Designation: Left support/Right support 
- Reference: LS/RS 
- Material: metal > aluminum 

 

Make the drillings 

 Start the Wood > Drilling function.  

 Set Mode = Non dynamic, then select the upper face of the bottom shelf top as the face to drill. 

  

 Select the cylinder of a support as the first alignment face or edge. 

Note: When making a drilling, selecting an existing cylinder, circle or axis allows you to automatically orient the 
drilling with the selected element. 

 In the Drilling models window, select Hole in Standard models. 

 Check Save as default, then click on OK to confirm. 

Note: Checking Save as default saves the drilling values for the following drilling operations. 

 Set the drilling: 

- Hole: Blind 
- Diameter: 20mm   
- Depth: 11mm 
- Bottom angle: 0° 

 

 Save the file using the disk icon. 

Note: Once the file has been saved in the library, simply click on the disk icon to save the modifications. 
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Exercise 2: Creating a cabinet component 
The goal of this exercise is to create the cabinet in a driver block, and then assemble 
it with dowels and cams. 

Concepts addressed: 

- Driver block 
- Propagations 
- Panels 
 
 

Creating a driver block component 

 
 
 

 
 
 
 

 

The driver block is used to drive a component from a block. 
This makes it easier to create and use all kinds of components that can be inserted in a rectangular block: 
cabinet, back of furniture, door, shelves… 
 

Cabinet component as 
driver block 

 

Insertion of the cabinet as driver block Assembly result 
 

 
  

   
Shelf component as driver 

block 
Component insertion Result 

 

 
  

 
 

Note 
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Create the driver block 

 Create a new Design document. 

 Create the driver block using the Assembly > Define component > Define drivers > Driver block function. 

 
 Enter db as the name of driving element. 

Note: The name and the designation of a driver block work the same as for a parameter. 

The name is the system name used by the parameter. It must be simple and cannot contain any spaces. The 
designation is what the user sees when using the parameter. It must be explicit and can contain spaces. 

 The lengths on X, Y and Z correspond to the default dimensions of the driver block. Keep the default 
dimensions. 

 Choose Default housing mode = Inside a block. 

Note: A driver block component can be inserted in two different ways: 

- Inside a block:  
 

 
- Housing: 

 
 

 Select Current coordinate system to position the driver block. 

 
 

 Enter Cabinet block as the designation of the driving element and click on OK to 
confirm. 

 
 
Note: The arrow on the driver block’s face represents the front of the driver block 
and shows the top of the driver block. 
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Create the cabinet parts 

 Make layer 1 current. 

 Create a length parameter: 

- Value = 19mm 
- Name: t.  
- Designation: Panel thickness. 

 
 Using the constrained block, create the 4 parts shown opposite. 

 

- The constrained blocks have a thickness = t. 
- The constrained blocks are placed inside the driver block. 
- The left-hand and right-hand sides of the cabinet cover the top 

and the base. 
 
Note: You can use the Automatic option to create the constrained blocks more quickly. 

 
 

 Define the four parts of the cabinet: 

- Designation: Top / Base / Left-hand side / Right-hand side 
- Reference: TO / BA / LS / RS 
- Material: wood > particule board  
- Coating: paint > mat white paint 

 

 Define the cabinet set: 

- Designation: Free-running sided cabinet 
- Reference: FRS-CAB 
- Main set: Sub-assembly 

Save the cabinet 

 Define the t parameter as a driving parameter using the Assembly > Define component > Define drivers 
function. 

 Use Assembly > Define component > Edit/save template to save the file in the library. 

 Select Save standard template. 

 In the window, set: 

- Standard: Training library 
- New family: Cabinets 
- New type: Cabinets 
- New variant: Free-running sides 
- Uncheck Supplier code. 

 Click on OK to confirm the window. 
  



Exercise 2: Creating a cabinet component  TopSolid’Wood Advanced 

20   Missler Software 

Assembling the cabinet 

Create predefined propagations 

 

 In a Design document, open Tools > Options > TopSolid’Wood Configuration > Propagations configuration. 

 Select Add propagation to create a new propagation.  

 Then double-click on the newly created line Untitled and name this propagation Dowels. 

 

 In the propagation list, modify the Right bound value on the first line to 80mm. 

 Use the Add range button to create the different ranges below.  
 

Left bound Right bound 

0mm 80mm 

80mm 200mm 

200mm 400mm 

400mm 650mm 

650mm Infinite 

 Then set the following propagations according to the ranges. 

 
 
 

 

As seen before, it is possible during assembly functions to use a certain type of propagation to configure the 
assembly. 
Predefined propagations can also be configured so that the propagation parameters don’t have to be filled for 
each assembly. 
These predefined propagations also define different propagation rules according to the length to assemble. 

 
 

 

Note 



TopSolid’Wood Advanced  Exercise 2: Creating a cabinet component 

Missler Software   21 

 Add a new propagation using Add propagation. 

 Name this propagation Cams. 

 Recreate the same ranges as for the Dowels propagation. 

 Set the different propagations as shown below. 

 

 Click on OK to confirm the window. 

Assemble the cabinet 

 In the free-running sided cabinet template, start the Dowel function.  

 Select Smooth pin, choose the code 30x8, and then click on OK to confirm. 

 

 Select the Filter mode and set Propagation = YES. 

 Select the face between the top and the left-hand side as the 
support face. 

 
 

Note: When the support face of the parts to assemble is rectangular, the Automatic option can be used to detect 
the start, terminate and centred automatically faces. 
 

 Select Automatic.  

 The Distribution definition window opens. To use here the previously configured predefined propagations, 
select the Dowels propagation in the Propagation name dropdown list. 

 
 

 Confirm the window with OK to assemble the parts. 
 
 
 
 
 
 

 Use Copy propagation to assemble other parts with the same propagation. 

 

 Repeat the previous steps to dowel assemble the four parts. 
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 Start the Cam function.  

 Select Wood eccentric assembly hinge with the code: ep 19. 

 
 Select the Filter mode and set Propagation = YES. 

 Select the contact face between the top and the left-hand side as 
the support face. 

 

 

 Then select the bottom face of the top as the face to drill for the 
case of the cam. 

 
 

 

 Use the Automatic option. 

 In the Distribution definition window, choose the Cams propagation as 
the predefined propagations, then click on OK to confirm. 

 
 

 Use Copy propagation to position the three other assemblies. 

 Save the cabinet. 
 
 
 

Creating the panels 

 

 

 

 

  

 
Creating panels allows edges and laminates to be placed on parts. 
Several elements are then generated: 

- A panel entity: Includes the part, the edges and the laminates. 
- A support: This is the part on which edges and laminates are placed. 
- Edges and laminates. 

 
It is then possible to use the panel entity or the support, depending on the manufacturing processes. For 
example, for the machining, if the part is machined before the edges are placed, the support will be used. But 
if the part is machined after the edges are placed, the panel entity will be used. 

 
 
                     Panel entity                    Support  -  Edges  -  Laminates 

Note 
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 In the Wood context, start the Panel function.  

 Open the panel advanced options.  

 Set: 

- Same characteristics for panel and support. 
This option automatically applies the same characteristics (designation, 
reference…) to the support and the panel entity. Thus, the part definition is 
done only once. 
 

- Simplified representation. 
The simplified representation is used to view only the edge textures and the 
laminates without displaying them in 3D. 
 
Note: For design purposes, it is strongly recommended that you always work 
in simplified representation when designing. This improves overall graphics 
performance during the designing. 
The detailed representation is used for example in the draft to view the real 
edges. 
 
 

 

 

 

 

 

- Assembly nature: Sub-assembly. 

The Sub-assembly mode for the panels displays the BOM of the edges and the 
laminates on additional lines. 

- Design for edges: Finished. 
- Do not make laminates. 

 Click on OK to validate the parameters. 

 Select the main face of the left-hand side as the reference face.  

The panel configuration window opens. 
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 Double-click in the Edge type – code box on the first line to select an edge: 

- Standard: TopSolid’Wood 
- Type: Thin edge 
- Variant: Flat edge 
- Version: 01 
- Code: ep 2 
- Material: PVC u 
- Coating: Oak 
- Codification: EDG-TH-2-PVC-OAK 

 
 
 
 
 

 Select Add to create the new edge codification, then click on OK to validate the edge. 
 
Note: Edge codifications are used to provide the manufacturing reference of edges for the bill of material.  
It is possible to use edges without codifying them by unchecking the All edges and laminates must have one 
codification option in Tools > Options > TopSolid’Wood Configuration > Edge/ Laminate. 
 
 
Each line corresponds to an edge of the part. By clicking on a line, the arrow 
corresponding to the selected edge turns red. 

 Uncheck the line of the rear edge so as not to place an edge on the rear edge of 
the panel.  

Its arrow then turns transparent. 

 Double-click in the Beginning cut type box to set the covering long side. 

 
 

 

 Confirm the window with OK to make the panel. 

 Repeat these operations to apply edges to the three other parts: 

- On the right-hand side, the rear edge is not placed. 
- On the top and the base, only the front edge is placed.  
 

 Save the cabinet. 
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Supplement: Predefined values 

 

 Start the Parameter > Modify parameter function. 

 Enter t as the parameter to modify and press Enter to confirm. 

 Open the advanced parameters >>.  

 Select Predefined values=0.  
 
The Predefined values window opens.  

 Enter the three values 16, 19 and 22. 

 Check Only those values. 

 Click on OK to confirm the window. 
 
 
 
 
 
 
 

Note: The Only those values option allows you to enter for this parameter only the predefined values indicated 
here. 
The Designation field is used to associate a designation to the predefined values. 
 

   

 Save and close the cabinet. 
 

  

Predefined values can be defined for a parameter. 
This means that, when using this parameter, it is possible to use one of the predefined values. 
This helps, for example, to set the panel thickness to certain values only. 
 

Note 
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Exercise 3: Creating a back of furniture in grooves 
In a library component, it is possible to define machinings that will be performed when the component is 
inserted. 
This is e.g. the case for cams and dowels which perform drillings after their insertion. 
This process will be used in the "Back grooves" component which will automatically 
perform the grooves once inserted. 

Concepts addressed: 

- Negative shifts on constrained blocks 
- Martyr parts 
- Component processes 
 

Creating the component 

Create the driver block 

 Create a new Design document. 

 Create the driver block using Assembly > Define component > Define drivers > Driver block: 

 

- Name of driving element: db 
- Keep the default dimensions 
- Default housing mode = Housing 
- Current coordinate system to position the driver block on the current 

coordinate system. 

 

- Designation of the driving element: Cabinet block 

 
 
 

Create the back 

 Make layer 1 current. 

 Use the Constrained block function to create the back:  

- Thickness = 8mm 
- Shift = -5mm on the 4 selected faces 
- Selected planes: 4 sides of the driver block 
- Positioning shift: 10mm 
- Positioning plane: Rear face of the driver block 
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Define the part and the set 

 Define the back using the Define part function: 

- Designation: Part 
- Material: wood > particule board. 
- Coating: paint > mat white paint. 

 Define the set using the Define set function: 

- Designation: Back grooves 
- Reference: BACK-GR 
- Main set: Single Unit 

 Save the component in the library using Assembly > Define component > Edit/save template > Save standard 
template: 

- Standard: Training library 
- Family: Cabinets 
- New type: Backs 
- New variant: Back grooves 

Creating the processes 

Create the martyr parts 

Note: The goal of creating the Back grooves component is that it can perform its grooves automatically when 
inserted in a cabinet. To do this, the grooves must be made in the component on "martyr" parts: these parts will 
be created without being defined so that they are not included with the component. 
 

 Make layer 2 current. 

 Change the design color to differentiate the martyr parts.  

 Use the Constrained block function to automatically create the 4 martyr parts 
on the sides of the driver block:  

- Thickness = 19mm 
- Selected planes: 4 sides of the driver block 
- Positioning: Outside the driver block 

 
 
 
 
Note: The martyr parts of a component should not be panel entities. 
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Making the grooves 

 Switch off layers 0 and 1. 

 Start the Groove function.  

 Set Sweep = Planar face and select the inner face of the base martyr part as 
the reference face. 

 Then select the rear edge (Y+) of the martyr part as the reference edge or 
curve for tool path. 

 The gap of the groove symbolized by the red arrow must be towards the inside 
of the part. If needed, click on the arrow to invert. 

 Click on Stop to validate the groove path. 
 

 
 
 
 

 
 

 Set the groove: 

- Tool type: Routers 
- Standard: Simple mill 
- Entry/Exit: Radius  
- Distance to start point/from terminate point: -6mm 
- Parameters: High arm 
- Gap distance: 10mm 
- Groove width: 8mm 
- Groove depth: 6mm 

 

 

 
 
Note: The distance to start point/from terminate point of -6mm is used to extend the groove by 6mm towards 
the outside of the part to match the extension of the back with a shift of 1mm. 

 

 Confirm the window with OK to make the groove. 

 Use Copy operation to perform the same groove on the three other martyr parts.  
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Define the grooves as component processes 

Note: Defining the grooves as component processes (also called component tools) allows these machinings to be 
performed when inserting the component. 

 Start the Assembly > Define component > Define tools function. 

 

 Set Operation type = Local operation on shapes. 
 

Note: A local operation on shapes corresponds to a performed machining. 
If the process is not a machining, it is possible to choose a shape subtraction or union. 
 

 Enter tool1 as the name of tool element and press Enter to confirm. 

 

 Modify the designation to Back grooves and press Enter to confirm. 

 
 
 

 In Local operation to insert in tool, select one of the grooves previously 
performed. 

Note: To select a machining, simply select a geometry produced by the machining: 
side edge, back face… 
If a geometry belongs to several machinings, it is possible to select the machining 
to be inserted. 
 
 
 
 
 

 Confirm the default local operation name. 

 Then select the three other grooves. 

Note: The selected operations are shown in red.  

 Once the four grooves have been selected, click on Stop to validate. 

 
 

 Confirm the Operation as tool definition window without changing anything. 

 Make layer 1 current, then switch off layers 0 and 2. 

 Save and close the document. 
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Exercise 4: Using the components in an interior design 
The goal of this exercise is to create an interior design, and then insert the standard components previously 
created. 

Concepts addressed: 

- Importing a DWG file 
- Using the layers 
- Making the room to fit out in 3D from 2D 
- Inserting standard components 
 
 
 
 
 
 

Importing and using a DWG file 

Import the file 

Importing a file in another format can be done directly using the Open function of TopSolid. 

 Start File > Open and click on the file Missler.DWG.  

 Always in the Open File window, set Open as: TopSolid’Design – Design. 

 

Note: It is possible to configure how to open a DMG file using the Configure button.  

 Then in the dialog bar set the file’s import parameters: 

 

- Unit: Set the unit to use for this document (m, mm, Km…). 
Select Unit = Automatic to automatically detect the unit of the document. 

- Standard: Set the type of drawing standard to use for this file (Iso, Ansi…). 
Select Standard = Automatic to automatically detect the standard of the document. 

 Click on OK to validate the parameters and close the Import Options window. 

 
Note: When imported, the file is automatically converted to the TopSolid format (.top) in a new document. 

 Save this document in a folder called Interior design and rename it Interior design.  

 Answer No to the Part definition window. 
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Explore the imported file 

Note: When a DXF or DWG file is imported in TopSolid, the drawing colors are automatically retrieved. 
Moreover, the overlays are imported on the TopSolid layers. The names of these overlays are also imported via 
the names of the layers. 
 

 Open the construction tree using Ctrl + ². 

 Go to the Layers tab.  
 

Note: The Layers tab of the construction tree displays the different layers of the 
document. 
 
Right-clicking on a layer allows you to make it current or active, give it a name or 
add elements. 

 
 

By default, only the non-empty layers are displayed. 

 Right-click > Definition on the first line Non empty layers and set: 

- Display = All layers. 
- Sort = Numerical and click on OK to confirm. 

  
 

Make the walls   

 Make layer 9 current and name it Walls.  

 Switch off layer 5 by double-clicking on it. 

 Start the Extruded function from the Shapes context.  

 Set New contour = Sketch and select New contour. 

 

 Then select Rectangular. 

 

 Select the bottom left-hand corner of the lounge as the first diagonal point. 

 

 Select the intersection point between the exterior wall (light blue) and the interior wall (black) as the second 
diagonal point. 
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 Extrude this wall in the Z+ direction to a height of 2500mm.  

 Repeat this operation to extrude a second wall perpendicular to the first one to the double door (purple). 
 

 

 Make several walls of the house in the same way. 

 

Make the columns 

 Use the same method to extrude the 3 columns of the lounge. 
 
 
 
 
 

Make the ground 

 Make layer 10 current and name it Ground.  

 Use the same method to extrude the ground on the whole plane in the Z- direction to a height of 100mm. 
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Using the standard components 

Draw the construction volumes 

 Make layer 11 current and name it Construction volumes. 

 Switch off layers 0 to 8. 

 Create a new sketch. 

 Use Contour > Rectangular to draw a rectangle.  

 

 Then click on Auto dimension to automatically place the dimensions of the rectangle. 

 

 The next dialog is used to place symmetry constraints on the dimensions. Click on OK. 

 Repeat the operation to draw four other rectangles as shown below. 

 

 Use Modify parameter to set the rectangle dimensions to the following values: 

- X=2000; Y=650 
- X=1500; Y=650 
- X=750; Y=500 
- X=750; Y=500 
- X=700; Y=500 

 Then place an alignment constraint between the lower segments of the rectangles and the inner edge of the 
low wall. 
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 Place a dimension between the rectangle of 2000mm and the right-hand column to a value of 1000mm.  

 Place alignment constraints between the rectangles to obtain the following result. 

 

Extrude the construction volumes 

 End the sketch. 

 Change the design color to cyan.  

 Start the Extruded function from the Shapes context. 

 Set Generatrix sketch = Global and Result = One shape per profile. 

 
Note: Generatrix sketch = Global is used to extrude any sketch in one go. 
Result = One shape per profile is used to obtain a distinct shape per drawn contour. 
 

 Then select the sketch. 

 In the advanced parameters >>, set Offset from starting curve = 100mm, then click on OK to confirm. 

 

 Extrude the blocks in the Z+ direction to a height of 300mm. 

 Using Attribute > Transparency, apply a transparency of 7 to the extruded blocks. 

 

Modify the construction volumes 

 Open the construction tree using Ctrl + ². 

 In the Main tab, right-click > Edit. 

Note: The Edit function is used to modify an element in the construction tree. This makes it easier to find all the 
elements and parameters used by this element. 
 

 Select the left-hand construction volume as the element to edit. 

 
 

 The extruded block is now open in the construction tree. 
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 Click on + to develop extruded shape on curves. 

All the elements that were used to create the extruded shape are shown here: 

- The generatrix: This is the sketch used for the extrusion. 
- The absolute coordinate system: This is the coordinate 

system which allowed the definition of the extrusion 
direction. 

- The extrusion length. 
- The offset from starting curve. 

 
Note: All the construction volumes have been extruded in a single operation. This means that the extrusion 
lengths, as well as the offsets from starting curves are merged between the blocks. 
To modify a volume without changing the others, the parameter must be replaced. 

Note: It is also possible to modify an extruded shape locally without changing the others using the Modify 

element function.  

 On Offset from starting curve, right-click > Replace.  

 Set Replacement = Local and Replacement parameter = 800. 

 Also replace the extrusion length by 1200. 
 

 

 Edit the two identical right-hand blocks: 

- Replace their extrusion length by 700mm  
- Replace their offset from starting curve by 1300mm. 

 Finally, edit the right-hand block to replace its extrusion length by 450mm. 
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Include the standard components 

 Make layer 12 current and name it Cabinets. 

 To include standard library components, use the Include standard function from the Assembly context.  

 In the Standard component inclusion window: 

- Select Training library in the dropdown list. 
- Select Cabinets > Cabinets > Free-running sides. 
- Click on OK to confirm. 

 
 
The Cabinet component is a Driver block component. When including this component, you will be asked to select 
the destination volume of the Driver block. 

 Set Housing mode = Inside a block and Hide block = NO. 

 

Note: The Housing mode = Inside a block mode has been set by default in the Driver block component to avoid 
setting it during its insertion. It is therefore possible to modify its inclusion mode. 
The Hide block option automatically hides the construction volume used. 
 

 Select the front face of one of the construction volumes as the cabinet block. 
The Driver block is automatically included in the construction volume.  
 
Note: The red arrows are used to modify the support planes of the driver block.  
 
 
 
 

 Set Multiple inclusion = YES to include the same 
Driver block component several times. 

 Select the front faces of the four other 
construction volumes, and then validate with OK. 

 
 
 
 
 
 

 

 Set Thickness of panels = 19mm and click OK. 

 Switch off layer 11 to hide the construction 
volumes. 
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Set the display mode 

Note: By default, the components of a standard library are inserted in detailed representation. 
As it is not recommended to work in this representation, the representation mode of the inserted elements must 
be changed. 
 
Note: To insert the standard components in simplified representation, select Tools > Options > 
Components > Components management > Representation: Simplified. 

 

 Open the construction tree using Ctrl + ². 

 In the Main set tab, right-click on the line ASSEMBLY, 
then click on Representation. 

 Set Representation = Simplified.  
 

Note: Representation = Mixed means that some elements are in simplified mode and others in detailed mode. 

Include the groove backs  

 Use Include standard to include the standard component Back grooves.  

 Set Housing mode = Housing. 

Note: To insert a Driver block component in housing mode like inside a cabinet, 
simply select one of the 4 inner faces of the cabinet. 

 
 

 Select one of the inner faces of a cabinet as the cabinet block. 

The driver block is automatically included in the inner volume of the cabinet. 

 Set Multiple inclusion = YES, then position the driver block in the four other cabinets. 

 

 Click on OK to validate the driver blocks. 

 Then create the processes of the Back component using the Automatic function. 

 
 
Note: To make the processes of a component after including it, use Assembly > Use process and select the 
component with the processes. 
The Automatic processes are only made on defined parts. 
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Include the shelf 

 Use Include standard to include the Wall shelf component.  

 Set the different parameters: 

- Shelf length = 1500mm 
- Shelf depth = 300mm 
- Shelf height = 250mm 
- Panel thickness = 19mm 

 
The Wall shelf component is calculated, and then inserted according to the parameter values that you entered.  

 Left-click in the space to release the component. 

 Then place three constraints on this component to position it: 

- Rear edge of the shelf / Wall, Distance = 0mm. 
- Base of the shelf / Top of the lower right-hand cabinet, Distance = 250mm. 
- Left-hand side of the shelf / Left-hand side of the lower right-hand cabinet, Distance = 0mm. 
 

 
 

Define the set 

 Define the set using Wood > Define > Define set > Characteristics: 

- Designation: Lounge fitting. 
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Exercise 5: Creating a counter with geometric drivers 
The goal of this exercise is to create a "Counter" component 
driven by a path, and then insert it in the interior design. 

Concepts addressed: 

- The component driven by a path or Component with 
geometric drivers 

- The pipe shape 
- The trimming by planes 
- The unbent parts 

 

Creating the component with geometric drivers  

Create the driving path 

 Create a new Design document. 

 Change the design color to blue (12). 

 Start the Curves > Circle function, and then draw a circle arc in Passage point mode. 

  
 
Note: The circle arc must be rather large to facilitate the design. 

 

 
 

  

 

The component driven by a path or Component with geometric drivers is used to create a component which 
will take the desired shape when inserted in an assembly. 
 
Here, the Counter component is designed according to the blue driving path. 
This means that any line or circle arc can be defined as a driving path when inserting the component. The 
component will take the desired shape. 
Below are two examples that show the insertion of the left-hand component on a line and a circle arc. 
 

 
 

Note 
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 Start the Edit > Break associativity function. 
 
Note: Breaking the associativity of an element breaks the links it has with its construction elements. It is 
therefore completely independent. 
This operation should be performed on the driving path of the component to avoid any errors when assembling. 

 In Elements to break their associativity, select the circle arc. 

The circle arc then becomes completely independent. 

 Start the Edit > Name function, and then select the circle arc. 

 Enter Name: t and Designation: Trajectory. 

  
 
Note: Naming an element makes it easier to find it in the design. 

 Make layer 1 current. 

 Start the Tools > Coordinate system > Coordinate system on curve and point function.  

Note: A coordinate system on curve and point is used to automatically place a coordinate system perpendicular 
to the path of a curve passing through a point. 

 

 Select the circle arc as the reference curve, then the right end of the circle arc as the origin point. 

 Select Quit, and then Set as current to be positioned along this coordinate system. 
 

Create other parameters 

 Using the Parameter > Create function, create the parameters shown 
opposite in Unit type = Length mode. 

 
 

 
 

 Open the list of parameters using Parameter > Edit list.  

 Make the parameters as drivers by changing No to Yes in the Driver column.  

Define the path as driver 

 Start the Assembly > Define component > Define drivers function. 

 Enter Driving element to insert: t and press Enter to confirm. 

 Confirm the default designation of the driving element. 

The t path is now a driver of the component. 

  



TopSolid’Wood Advanced  Exercise 5: Creating a counter with geometric drivers 

Missler Software   41 

Save the component 

 Save the component in the library: Assembly > Define component > Edit/save template > Save standard 
template. 

 Set: 

- Standard: Training library 
- Family: Furniture 
- New type: Counter 
- New variant: Interior counter 

 Click on OK to validate the window. 

Drawing the parts 

Draw the bent front 

 Switch off layer 0 and set the design color to black. 

 Start a new sketch and draw a rectangular contour to the left of the coordinate system. 
Use Auto dimension to automatically apply the dimensions. 

 Delete the height dimension of the rectangle.  

 Use Modify parameter to modify the width of the rectangle to 10mm.  

  

 Then dimension:  

- from the top of the rectangle to the X axis with a nominal value = h; 
- from the bottom of the rectangle to the X axis with a nominal value = 70mm; 
- from the right-hand side of the rectangle to the Y axis with a nominal value = td. 

 End the sketch.  
 
 

Draw the tops and the baseboards 

 Make layer 2 current. 

 Draw four rectangular contours as shown opposite in 
Orientation constraint mode. Use Auto dimension to place the 
dimensions automatically. 

 Use Modify parameter to modify the rectangle dimensions to 
the dimensions shown opposite. 
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 Apply: 

- an alignment constraint between the bottom of the baseboards (rectangles 100x10) and the X axis; 
- an alignment constraint between the bottom of the base (rectangle 200x19) and the top of a baseboard; 
- an alignment constraint between the right-hand side of the base and the left-hand side of the bent front; 
- a coincidence constraint between the top right-hand point of the top and the top left-hand point of the 

bent front. 

 Then dimension the shift of the baseboards in relation to the base to 30mm. 

 

Draw the side 

 Make layer 3 current. 

 In a new sketch, draw a four-segment contour. 

 Apply: 

- a coincidence constraint between the two upper points and the two lower points of the top. 
- a coincidence constraint between the bottom right-hand point and the bottom left-hand point of the bent 

front 
- an orientation constraint of the lower segment along X 
- a coincidence constraint between the left-hand segment and the bottom left-hand point of the base 

 End the sketch. 
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Draw the shelf 

 Make layer 4 current. 

 Start a new sketch and draw a rectangular contour. 

 Dimension the height of the rectangle to 19mm. 

 Place an alignment constraint of the right-hand side of the rectangle on 
the left-hand side of the bent front. 

 Dimension the distance between the bottom of the shelf and the top of 
the base. Set Nominal value = sh. 

 Place a coincidence constraint of the bottom left point of the rectangle 
on the left-hand segment of the side. 

 End the sketch. 

 
 
 
 
 
 
 
 
 

Making the parts 

Configure the current material and coating 

Note: It is possible to define a current material and a current coating which will be used by the new extruded 
shapes. 
When creating a number of parts with the same material and coating, this avoids you to set the material and the 
coating for each part. 

 In the status bar at the bottom of the graphical zone, click on the Mat = … button. 

  
 
Note: This box shows the default material. 
If the Mat = … button is not displayed, right-click on the status bar and select Material and coating in the list. This 
list displays all the information that can be shown in the status bar. 

  
 

 Once you clicked on the button, set the current material and coating: 

- Current material: wood > particule board. 
- Current coating: paint > glossy white paint. 

 Click on OK to confirm. 

Curving the low parts 

Note: The pipe shape can be used to extrude a 2D (Section curve) along a path (Guide curve). 

 Start the Shape > Pipe function.  

 Set Pipe = On curves and Follow = Subsequent operations. 
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 Switch on layer 0, and then select the blue driving path as the guide curve. 

 Adjust the red arrow so that it goes from the sketch to the path. This arrow is used to set the pipe shape 
direction. 

 Set Corners type = Rounded, Curves = Visible, Generatrix sketch = Local and Type = Solid. 

  
 
Note: Corners type = Rounded is used to round the pipe shape when the guide curve has a sharp corner. 
Curves = Visible keeps the curves visible on the screen after creating the pipe shape. 
Generatrix sketch = Local is used to select only one contour when a sketch contains several contours. 

 In section curves or texts, select the sketch of the base. 

 

 Repeat the operation to create pipe shapes for the two baseboards, the shelf and the bent front. 

Note: The Curves = Invisible mode is always used by default. For this exercise, set the mode to Curves = Visible at 
each use. 
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Curving the counter top 

Note: As the top is longer than the rest of the counter, its guide curve must 
be extended to the desired length. 

 Make layer 5 current and switch off layers 0 to 3. 

 Change the design color to green (10). 

 In the Curves context, start the Copy edge function. 

 Set Mode = Edge. 

 Select the upper inner edge of the bent front as the edge to copy. 

 Start the Curves > Extend function, and then select the copied green 
curve of the left-hand side. 

 
Note: The Extend function modifies the length of a curve by adding or 
removing a distance. 

  

 Set Type = Curvature, Mode = Extend length and Length = p to set the length of the extension. 

 

 Click on OK to confirm. 

 Switch on layer 2, and then create the pipe shape of the top by selecting the extended green curve as the 
guide curve.  

  



Exercise 5: Creating a counter with geometric drivers  TopSolid’Wood Advanced 

46   Missler Software 

Repeat a sketch and extrude the sides 

 Make layer 6 current and switch on layer 3 containing the sketch of the side. 

 Start the Current coordinate system function  in order to change the current coordinate system, and 

then select Absolute coordinate system as the named coordinate system.  
Note: Since the absolute coordinate system is on layer 0, this layer is automatically turned on. 

 Start the Edit > Repeat function. 

 In Template elements to repeat, select the sketch 
of the side. 

 Set Propagation = On curve. 

 Select the blue driving path shown opposite as the 
curve to propagate from the start. 

 
 
 
 
 

 Set:  

- Distribution mode = Distribute 
- Distance computing mode = Arc length  
- Transformation mode = Constraint coordinate system 

  

 Validate these parameters, and then enter Number of instances: 2. 

  

 Start the Extruded function and set Extruded shape on = Curves, Generatrix sketch = Local and Result = One 
shape per profile. 

 In Section curves or texts, select the Element detection function.  

Note: The element detection is used to select only one of the elements belonging to an assembly or a repetition. 
In this case, in order to extrude only one sketch of the repetition, the detection should be used to specify the 
sketch to be extruded. 

 Select the right-hand sketch as the element for detection, and then click on OK to confirm. 

  

 Extrude this sketch towards the inside of the 
counter to a height of 19mm. 

 Repeat the operation to extrude the second side. 
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Trim the parts 

Now let’s trim the shelf, as well as the base in relation to the sides. 

 Start the Shapes > Trim function.  

 Set Trim = By plane. 

 In Shape(s) to trim, use the selection in order to select several shapes. 

 
 Select the shelf and the base, and then click on OK to confirm. 

 Select the inner face of the side as the trimming plane. 

 The red arrow represents the side of the material to be removed.  
Adjust the arrow so that it shows the outside of the counter, and then 
click on OK to confirm. 

 Set Hide tools = NO and click on OK to confirm. 

 Repeat the operation to trim the parts in relation to the inner face of the 
second side. 

 
 
 

Subtract the parts 

Subtracting the sides from the baseboards allows the notches to be made. 

 Use Shapes > Subtract.  

 In Shape(s) to modify, use the selection  in order to select several 
shapes. 

 Select the two baseboards, and click on OK to confirm. 

 Set Hide tools = No. 

 In Tool shape(s) to use, use the selection,  select the two sides 
and click on OK to confirm. 

The sides are subtracted from the baseboards. 
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Defining the parts 

Define the planar parts 

Note: Since the counter parts are curved parts, you must first draw the lines representing the lengths of the parts. 
This will allow the precise cut of the parts to be calculated. 
 

 
 

 Make layer 7 current. 

 Change the color to black. 

 Use the Curves > Line function to draw the length axes of the top, the 
base and the shelf as shown opposite. 

 
 
 
 
 
 

 Start the Wood > Define > Define part function.  

 Select the counter top as the part to define. 

 Set Select axis automatically = No, Bent part = No, and then click on OK to confirm. 

 

Note: Since the part is a curved part, the axes must be selected manually in order to control the cutting-up 
dimensions. 

 Select the previously drawn line as the length axis, and click on OK to confirm. 

 

 Then select the edge of the counter top width as the width axis, and click on OK to confirm. 

 
 

The cutting-up axes are placed on the part and the rectangular cut is calculated.  
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 Enter the following designations and references. 

  

 For the top only, modify the coating to paint > mat grey paint. 

Define the bent parts 

Note: The baseboards and the bent front are bent parts. To calculate their precise cut, the parts must be 
unfolded. 
Unfolding a part also allows this part to be machined before folding. 

 

 Start the Wood > Define > Define part function, and then select the bent front of the counter. 

 Set Select axis automatically = YES and Bent part = YES, and then validate with OK. 

  

The settings for the unfolding calculation then appear. 

 Enter: 

- Thickness = 10mm 
- Neutral fiber coefficient = 0.5 
- Level = 8 

  

Note: The thickness corresponds to the thickness of the part to be unfolded. 
The neutral fiber coefficient corresponds to the position of the neutral fiber on the panel thickness. A value of 0.5 
means that the neutral fiber is positioned in the middle of the part to unfold. 
The layer corresponds to the layer on which you want to place the result of the unfolding. 
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- Follow tangent faces = YES 
- Drills on reference faces = NO 

  

Note: It is possible to unfold several faces of a part in one go. The Follow tangent faces option is used to 
automatically select the faces that are tangent to the selected face. 
The Drills on reference faces option applies the drillings on the reference face to the unfolding. Only the drilling 
operations will be applied to the unfolding. 

 Select the outer face of the bent front as the face to unwind. 

 Click on OK to confirm. 
 

 
 
 
 
 
 
 
 
 
 
 
Note: To position the unfolding, an origin coordinate system, as well as a destination coordinate system must be 
selected. 
It is possible to select one of the axes automatically placed on the part corners as the origin coordinate system. 

 Select the axis at the top right of the bent front as the origin coordinate system. 

 

 Select any point to the right of the counter as the destination coordinate system to position the unfolding. 

 Switch on layer 8. 

Note: The unfolding can be moved on the point of the destination coordinate system later using the Move 

parents function.  

 

 In the part definition, enter: 

- Designation: Bent front. 
- Reference: BF. 
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 Click on OK to confirm. 

 Repeat the operations to unfold the two other baseboards: 

- Designations: Baseboard 1 / 2 
- References: BA 1 / 2 
- Coating: paint > mat grey paint 

 
 
 
 

Define the set 

 Define the set using Wood > Define > Define set > Characteristics: 

- Designation: Interior counter 
- Reference: IC 
- Main set: Sub-assembly 

 Save and close this file. 
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Using the component 

Create the destination path 

 Open the file Interior design. 

 Make layer 13 current. 

 Set the layer name = Counter. 

 Draw the sketch shown opposite.  

- The left-hand point of the arc is coincident with 
the left-hand wall. 

- The circle arc is perpendicular to the left-hand 
wall. 

 Then place the dimensions as shown opposite. 

 Finish the sketch. 
 
 

Insert the component 

 Use the Assembly > Include standard function.  

 Select the component Furniture > Counter > Interior counter, then click on OK to confirm. 

 Set as drivers: 

- Trajectory shift = 0mm 
- Top height = 800mm 
- Shelf height = 350mm 
- Top extension = 1000mm 
- Trajectory: Select the sketch created previously 

 
The component is automatically calculated according to the parameters specified and the selected path. 
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Note: Depending on the direction the circle arc is drawn, the component may be calculated on the other side of 
the circle arc. 

 

 To invert the path direction: 

- Delete the component.  
- Start the Curves > Origin function, and then select the previously drawn sketch as the curve to modify. 

The arrow that appears represents the curve direction. This direction is used to calculate the component. 

 

- Invert the direction of the circle arc by clicking on the red arrow. Click on OK to confirm. 
- Include the component again as shown above. 
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Exercise 6: Creating a door 
The goal of this exercise is to create a "Door" component as driver block. To make 
this component, you must first create the moulding tool of the door, the hinges, as 
well as the handle. 

Concepts addressed: 

- Moulding/Counter moulding tool 
- Door as driver block 
- Use of 3D components (hinge and handle) 

 
 

Creating a moulding tool 

Note: Creating a moulding tool allows you to create your own tools 
available in production. 
 

Create the profiles 

 Create a new Design document. 

 On layer 1, draw the sketch shown below: 

 

 End the sketch, and then draw the new sketch shown below. 

 
 

Note: In order to obtain a correct result during the machining (TopSolidWood’Cam or machining interfaces), it is 
necessary to draw the precise profile of the tool (radius, teeth, height…). However it is recommended to simplify 
the tool path to optimize the software performance. 
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 Switch off layer 0, and then create the two coordinate systems 2 axes shown below using offset points. 

 

 Save this file in the standard library using Assembly > Define component > Edit/save template > Save 
standard template: 

- Standard: Training library 
- New family: Tools 
- New type: Moulding tools 
- New variant: Chamfer Panel moulding 

Define the tool 

 To define the tool, start the Wood > Define > Define tool function.  

 Set Mode = Moulding and select the left-hand sketch as the tool curve. 

 

 Enter: 

- Tool name: tool1 
- Tool designation: Chamfer Panel moulding 
- Tool number: 105 

  
 
Note: The tool number is the tool number which will be used during exports for machining (TopSolid’WoodCam 
or machining exports). This field can be left blank; the number used will be the one set by default. 

 Click on OK to confirm the parameters, and then select the left-hand coordinate system as the position 
coordinate system. 

 Enter: 

- Position name: origin 
- Position designation: Tool origin 

  

 Set Tool radius: 45 and Cut depth: 15.  

  

The tool is now defined and can be used to make the mouldings. 
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Define the counter moulding tool 

 Start the Wood > Define > Define tool function.  

 Set Mode = Counter moulding, and then select the right-hand sketch as the tool curve. 

  

 Enter: 

- Tool name: tool2 
- Tool designation: Chamfer panel counter moulding 
- Tool number: 106 

 Select the right-hand coordinate system as the position coordinate system. 

 Enter: 

- Position name: origin2 
- Position designation: Tool origin 2 

 Set Tool radius: 45 and Cut depth: 15.  

 Save and close this file. 
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Creating a door component 

Create the parameters 

 Create a new Design document. 

 Create a driver block using Assembly > Define component > Define drivers > 
Driver block. 

 Set: 

- Name of driving element: db 
- Default housing mode = Housing 
- Select Current coordinate system 
- Designation of the driving element: Cabinet block 

 Create the 3 parameters below in Unit type = Length mode: 

- Value: 20; Name: cth; Designation: Crosspiece thickness 
- Value: 80; Name: cwi; Designation: Crosspiece width 
- Value: 2; Name: dg Designation: Door gap 

 Using the Parameter > Edit list function, define these parameters as drivers. 

   

 Save this file in the library using Assembly > Define component > Edit/save template > Save standard 
template. 

- Standard: Training library 
- Family: Cabinets 
- New type: Doors 
- New variant: Glass panel door 

Create the parts 

 Make layer 1 current. 

 Start the Constrained block function.  

 Set First shift = dg and Thickness = cth. 

 

 Select the top face of the driver block as the first plane. 

 Set Mode = Faces and enter second shift = dg. 

 Select the lower face of the driver block as the second plane. 

 

 Enter First shift = dg and select the left-hand face of the driver block as the 
first plane. 

 Set Mode = Length and enter dimension = cwi. 

 Adjust the red arrow so that the length of the constrained block is towards the 
inside of the driver block as shown opposite. 

 
 

 Select the front face of the driver block as the positioning plane.  

 Adjust the positioning yellow arrow so that the constrained block is placed 
inside the driver block. 
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 Make the three other parts as constrained blocks as shown opposite. 

- For the top crosspiece: Length = 2*cwi 
 
Note: At this time, it is normal that the parts overlap. They will subsequently be set 
to dimensions during the counter moulding operation. 

 
 
 
 
 
 

Saw the top crosspiece 

 Switch off layer 0. 

 Create a constrained coordinate system on a face: Tools > Coordinate system > Constrained coordinate 

system on face.  

 Set Mode = Non dynamic, then select the front face of the top crosspiece as the support face. 

 Then select: 

- First edge: The lower edge of the crosspiece 
- Parallel face or edge: The upper edge of the crosspiece 
- Second edge: The left-hand edge of the crosspiece 
- Parallel face or edge: The right-hand edge of the crosspiece 

A coordinate system centered on the face is then automatically created. 

 Use the Current coordinate system function and select the constrained coordinate system on face to make it 

current.  

 In a new sketch, draw the line shown below: 

- The left-hand point is coincident with the left-hand edge of the crosspiece. 
- The left-hand point is dimensioned to a distance of cwi from the upper edge. 
- The right-hand point is coincident on the lower right-hand corner of the crosspiece. 

  

 In the Wood context, use the Sawing function to saw the top crosspiece in relation to this line.  
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Create the glass panel 

 Make layer 2 current and change the design color to blue. 

 Start the Constrained block function.  

- Enter First shift = -13.5mm and Thickness = 5mm.  
- Select the lower edge of the sawn top crosspiece as the first plane. 
- Enter Second shift = -13.5mm and set Allow non parallel faces = YES. 

  

Note: Making a constrained block by allowing non parallel faces helps you create 
triangle and trapezoidal parts as constrained blocks. 

- Select the upper edge of the bottom crosspiece as the second plane. 
- Enter First shift = -13.5 and select the left-hand edge of the right-hand jamb 

as the first plane or point. 
- Set Mode = Face and Second shift = -13.5, then select the right-hand edge 

of the left-hand jamb as the second plane or point. 

The trapezoidal constrained block is automatically created. 
 
 

 Enter Positioning shift = 10mm, then select the front face of the top crosspiece 
as the positioning plane. 

 Adjust the red arrow outwards and the yellow arrow as shown opposite. 

Note: The red arrow corresponds to the positioning shift direction. 

 Click on OK to validate the constrained block. 
 
 
 
 
 
 
 
 

Perform the mouldings 

 Make layer 1 current and switch off layer 2. 

 Start the Moulding function from the Wood context.  

 Set Sweep = Planar face, then select the front face of the left-hand jamb as the 
reference face. 

 Select the inside front edge of the jamb as the reference edge or curve for tool 
path. 

 The side of the tool (large red arrow) must be towards the outside of the part.  

 The machining direction (small red arrow) can be left by default. 

 Click on Stop to validate the path. 
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The Parameters window of the moulding opens. 

 Select Training library in the Standard dropdown list. 

 Select the standard Tools > Moulding tools > Chamfer panel moulding. 

 Set:   

- Entry/Exit: Radius  
-  Distance to start point/from terminate point: 0mm 
- Parameters: Tangent and Rounded 

- X dimension: 0mm 
- Z dimension: 0mm 
- Angle: 0° 

 Validate the window to perform the moulding. 

 Then use the Copy operation function to perform the same operation on the 

three other parts.  
 
 
 
 
 
 

Perform the counter mouldings 

 Start the Counter moulding function.  

Note: The Counter moulding function is used to automatically perform the counter moulding on parts, based on a 
moulding already done. However, the counter moulding tool 
should first be created in the standard of the tool. 

 Select the left-hand jamb as the shape to modify. 

 Select the moulding of the top crosspiece as the reference 
moulding. 

 Confirm the default parameters with OK to perform the 
counter moulding. 

 
 

 Then perform the following counter mouldings: 

- Shape to modify: Bottom crosspiece; Reference moulding: Left-hand jamb. 
- Shape to modify: Right-hand jamb; Reference moulding: Bottom crosspiece. 
- Shape to modify: Top crosspiece; Reference moulding: Right-hand jamb. 

 Display layer 2. 
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Define the parts 

 Using the Define part function, 
define the different parts of 

the document.  

 For the jambs and crosspieces: 

- Material: wood > beech 
- Coating: paint > mat grey 

paint 

 For the glass: 

- Material: glass > glass 
- Coating: No coating 

 
 

Define the set 

 Use the Define set function to define the set:  

- Designation: Glass panel door 
- Reference: GPD 
- Main set: Sub-assembly 

 Save and close the component Glass panel door. 
 

Creating a handle component 

 Open the provided file Line handle. 
 
Note: To design this component, refer to the TopSolid’Wood 
Basics Training Guide, supplement of Exercise 6: Configured line 
handle. 

Save the component 

 Save this component in the training library: 

- Standard: Training library 
- New family: Hardware 
- New type: Handles 
- New variant: Line handle 

Create the martyr part 

 Make layer 1 current. 

 In the Shapes context, start the Block function, and then set:  

- X position = Centered; X length = hl+50. 
- Y position = Centered; Y length = 50. 
- Z position = Below; Z length = 19. 

 Then position the block by selecting the coordinate system origin as the alignment point. Press Esc on the 
keyboard to exit the function. 
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Make the drillings 

 In the Wood context, start the Drilling function.  

 Set Mode = Non dynamic and select the top face of the martyr part as the face to drill. 

  

 Select the left-hand vertical cylinder of the 
handle as the first alignment face or edge. 

 Then set: 

- Hole  
- Through one 
- Diameter: 4mm 

 

 Perform the same drilling on the top face of the martyr part in relation to the right-hand vertical cylinder of 
the handle. 

 
 

Define the drillings as component processes 

Note: Defining the drillings as component processes allows the drillings to be performed when inserting the 
component.  

 Switch off layer 0. 

 Start the Assembly > Define component > Define tools function. 

 

 Set Operation type = Local operation on shapes. 

 Enter Name of tool element: tool1 and press Enter to confirm. 

 

 Modify the designation to Handle drillings and press Enter to confirm. 

  

 In Local operation to insert in tool, select one of the drillings previously performed. 

 Confirm the default local operation name. 

 Select the second drilling, confirm its default name, and then validate the operation selection with Stop.  

 Confirm the Operation as tool definition window without changing anything. 
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Create a key point 

 

 

 Change the design color to blue. 

 Create a coordinate system on a point using Tools > Coordinate system > Coordinate system on point.  

 Select the origin of the current coordinate system as the origin point in order to create a new coordinate 
system like the current coordinate system. 

Note: In order to distinguish the key points from the absolute coordinate system, the absolute coordinate system 
should not be defined as a key point. 

That’s why a new coordinate system identical to the absolute coordinate system is created here. 

 Start the Assembly > Define component > Define key points function. 

 

 Select the coordinate system created before as the key point or key coordinate system to insert. 

 
 

 Enter Name of key coordinate system: cs1. 

 

Note: To be able to interchange two components positioned by a key point, the key points must have identical 
names. 
Here, the key point is named cs1 pour Coordinate system 1. 

 Enter Designation of key coordinate system: Handle middle. 

   
  

 

A key point is used to quickly position a component in relation to a coordinate 
system. 
This type of component positioning is often used for components such as 
hardware, which are positioned identically. 
 
The key point is defined in the component by a coordinate system. If the 
component can be positioned in many different ways, it is possible to define 
several key points. The key point to be used is then selected when positioning 
the component. 

 
 

Note 



Exercise 6: Creating a door  TopSolid’Wood Advanced 

64   Missler Software 

Create a catalog 

 

 Create the catalog using Assembly > Define component > Edit catalog header. 

 

 Then select All parameters and texts in the dropdown list to drive all the 
document parameters in the catalog. 

 
Note: The catalog of the component is automatically generated in Excel format. If Excel is installed on your 
computer, the catalog will be opened in Excel; if not, the catalog will be opened with the Notepad. 
 
The first column of the $code catalog is used to enter the component code 
which will be displayed in TopSolid.  
The different parameters to configure according to the codes are on the next 
columns. 

 Fill in the columns as shown opposite. 

 Save and close the Excel file. 

 Save the Line handle component, and then close it. 

Include the handle 

 From a Design document, edit a standard component using Assembly > Define component > Edit/save 

template > Edit standard template.  

 Select the component Cabinets > Door > Glass panel door in the training library, and then validate with OK to 
open this document. 

 Make layer 3 current. 

 Include the line handle using the Assembly > Include standard function. 

 In the component inclusion window, select Code: L256. 

  

 Position the handle on the left-hand jamb. 

 Select the left-hand edge of the jamb as the first alignment edge. 

 Enter distance = -(cwi-15)/2. 

  

 Select the lower edge of the bottom crosspiece as the second alignment edge, 
then the upper edge of the top crosspiece as the parallel face or edge in order 
to center the handle on the door height. 

 
  

 

If a component (furniture or hardware for example) is only available in certain dimensions, it is possible to 
create a catalog. 
This catalog will be used to automatically configure one or more component parameters in relation to a 
chosen code. 
 

 
 

 

Note 
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 Click on Stop so that the handle is not repeated. 

 Select Automatic to automatically create the tools of the handle and drill the 
left-hand jamb. 

 
 
 
 
 
 
 
 
 
 
 

Creating a hinge component 

 

 
 

Use the body of the hinge 

 Open the provided file Body CLIP top 75t1750.top. 

 Save this file in the training library: 

- Family: Hardware 
- New type: Hinges 
- New variant: Inserted hinge body 107° 

 Define the set: 

- Designation: Inserted hinge body 107° 
- Reference: 75t1750 
- Supplier: Blum 
- Main set: Single unit 

 Make layer 1 current. 

 Create the martyr part on the support plane of the hinge. 

 On the martyr part, create two blind holes aligned on the drillings 
of the hinge’s screws:  

- Diameter: 5mm  
- Depth: 12mm 
- Bottom angle: 0°. 

 
  

 

Hardware suppliers propose to provide the 3D geometries of their hardware 
parts. 
These 3D files can be opened and used in TopSolid’Wood, but to be used 
optimally these components should be made "intelligent" by assigning 
processes and key points to them. 
 
For information, a 3D component library from the hardware manufacturer 
BLUM is available on the Installation DVD (Disc 2). 
This exercise is based on a hinge base and a hinge body from this library. 
 

Note 
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 On the martyr part, create a blind hole aligned on the hinge:  

- Diameter: 35mm  
- Depth: 12mm  
- Bottom angle: 0°. 

 
 

 Define these drillings as component tools: 

- Name of tool element: tool1 
- Designation of the tool element: Door drillings 

 Insert the 3 created drillings in this tool. 

 Save and close the file. 

Use the base of the hinge   

 Open the provided file Base CLIP top 174e6100_01.top. 

 Save this file in the training library: 

- Family: Hardware 
- New type: Hinges 
- New variant: Base CLIP TOP 

 Define the set: 

- Designation: Base CLIP TOP 
- Reference: 174e6100_01 
- Supplier: Blum 
- Main set: Single unit 

 Make layer 1 current. 

 Create the martyr part on the support plane of the 
base. 

 On the martyr part, create two blind holes aligned on the drillings of the base’s screws:  

- Diameter: 5mm 
- Depth: 12mm 
- Bottom angle: 0° 

 Define these drillings as component tools: 

- Name of tool element: tool1 
- Designation of the tool element: Base drillings 

 Insert the 2 created drillings in this tool. 
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Create the mounted hinge component 

 Create a new Design document. 

 Include the standard component Inserted hinge body 107°. 

 Select Other positioning.  

 Select the absolute coordinate system of the body in Positioning 
coordinate system, then select the absolute coordinate system of 
the new document in Destination coordinate system.  

 Repeat the same operation to assemble the base of the hinge. 
 
Note: In general, when assembling hardware parts provided by the 
manufacturers, positioning the elements by absolute coordinate system 
on absolute coordinate system allows them to be exactly positioned 
relative to each other. 

 Save the mounted hinge in the training library: 

- Family: Hardware 
- New type: Hinges 
- New variant: Inserted hinge 

 Define the set: 

- Designation: Inserted hinge 
- Supplier: Blum 
- Main set: Sub-assembly 

 

Create the key point of the hinge 

 Create a center point using Tools > Points > Center key point.  

 Select the circle arc of the hinge body as the reference element as 
shown opposite. 

 
 
 
 

 
 
 
 

 Create a coordinate system on two axes: Tools > Coordinate system > 

Coordinate system 2 axes.  

- For the X axis, use the Through point option, select the center point 
created, and then Y-. 

- For the Y axis, use the Through point option, select the center point 
created, and then X-. 

 Define the coordinate system you just created as a key point: Assembly 
> Define component > Define key points. 

- Name of key coordinate system: cs1 
- Designation of key coordinate system: Door hinge reference 

 Save and close the file.  
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Insert the hinge on the door 

 Using Assembly > Define component > Edit/save template > Edit standard template, edit the standard 
component Glass panel door. 

 Create a new parameter using the Parameter > Create function. 

 Set Unit type = No unit, and then select Tabulated values. 
 
Note: Unit type = No unit is used to create a parameter that allows a quantity to be varied. Here, this parameter 
will be used to vary the quantity of hinges on the door. 
A parameter with tabulated values modifies the value of a parameter according to the value of another 
parameter. Here, the number of hinges will vary depending on the height of the door. 
 

 Enter Reference parameter: db.z 
Note: As a reminder, the door has been designed on the basis of a 
driver block.  
This driver block has been named db, so the db.z parameter is the 
dimension of the driver block on the Z axis, i.e. the height of the 
component. 
 
The Tabulated values table opens.  

 Create the different lines by entering the reference values of 
db.z and the values as shown opposite. 

The result is the following, with the door height as reference: 

- from 0 to 650mm => 2 hinges 
- from 650 to 1100mm => 3 hinges 
- from 1100 to 1900mm => 4 hinges 
- beyond 1900mm => 5 hinges 
 

 Click on OK to confirm the window. 

 Enter: 

- Name: hn 
- Designation: Number of hinges. 

 

 Insert the hinge: Assembly > Include standard. 

 Select the rear face of the right-hand jamb as the destination coordinate 
system. 

 Select the left-hand edge of the right-hand jamb as the first alignment face or 
edge, as shown opposite. 

 Enter distance = 24.5-dg. 

 Select the lower edge of the bottom crosspiece as the second alignment face 
or edge. 

 Enter Distance = cwi + 40. 
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 Select the Repeat option to directly repeat the hinge.  

 Select Propagation: Linear, Propagation direction: Y+. 

 Enter Total distance = db.z-(2*cwi)-80. 

  

 Enter Total number: hn 

 

 Select Automatic to perform the drillings of the hinges on the door. 

 Save and close this component. 
 
 
 

Using the door 

 Open the file Interior design.top. 

 Make level 14 current and set its name to Cabinets elements. 

 In the Assembly context, use the Include standard function to include the 

door component.   

 Then include the door as driver block in the left-hand cabinet. 
 

 
 

 Validate the default values of the driving parameters, and then perform the machinings using the Automatic 
option. 

Note: The tool processes defined in a component are automatically inherited at each assembly level .  
Here, the tools of the base’s drillings are automatically inherited, then performed on the cabinets. 
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Supplement: Declaring the handle as a sub-component 

 

 Edit the template document of the door: Assembly > Define component > Edit/save template > Edit 
standard template. 

 Define the sub-component function: Assembly > Define component > Define sub-component. 

  

 Select the line handle as the component. 

 Enter Name = Handle, and then press Enter to confirm. 

  

Note: Three options are available to configure the sub-component: 

- Code: Used to modify the catalog code of the sub-component. 
- Variant: Used to interchange the sub-component with another one. 
- Allow suppression: Used to delete the sub-component. 

 Check the Code option and click on OK to validate. 

 Then click on Stop.  
 
The handle is now defined as a sub-component. It will then be possible to modify its catalog code after the door 
insertion. 

 Save and close the door component. 

 Open the file Interior design.top. 

 Start the Modify element function, and then select the door.  

 Click on the Sub-component button to modify a sub-component of the door.  

  In the window that has just opened, unfold the node of the door, click on Line handle, and then click on OK 
to confirm. 

 Modify the code of the handle and click on OK to confirm. 

The handle is then modified in the assembly.  

 

It is possible to declare several elements of a component as sub-components. This allows you to make changes 
to the sub-component once the component has been included. 
In the case of the door with the handle, declaring the handle as a sub-component will allow the handle to be 
modified or interchanged with another one, once the door has been included. 
 

 

Note 
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Exercise 7: Creating glass shelves 
The goal of this exercise is to make a "Glass shelves" component in a driver block.  

Concepts addressed: 

- The linear constraint distribution of a constrained block 
- The measured parameter 
- The multi-drilling 
- The driver propagation 

 

Creating the component 

Create the parameters 

 Create a new Design document. 

 Create a driver block: 

- Name: db 
- Default housing mode: Housing 
- Designation: Cabinet block 

 Create a parameter, then define it as a driver: 

- Unit type = No unit 
- Value: 3 
- Name: ns 
- Designation: Number of shelves 

Save the component 

 Save this component in the training library: 

- Family: Cabinets 
- New type: Separation panels 
- New variant: Glass shelves 

Create the shelves 

 On the layer 1, create the shelves as constrained blocks: 

- Thickness = 5mm 
- Planes: 4 faces of the driver block 

 When selecting the positioning plane, use the Linear constraint option. 

 
 
Note: The Linear constraint option is used to repeat the constrained block. 

 Select the low face of the driver block as the start face or edge. 

 Select the top face of the driver block as the terminate face or edge. 
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 In the distribution definition window, select the 
Advanced distribution mode. 

 Set: 

- Check Unitary step 
- Step (p): 32mm 
- Minimum distance to start: 130mm 
- Minimum distance to terminate: 130mm 
- Element number: ns=3 
- Check Give priority to ends 

 
Note: The Advanced mode in Unitary step is used to 
distribute a given number of elements with minimum 
start and terminate distances.  
With the 32mm unitary step, the gap between the 
elements will always be a multiple of 32mm. 
 
 
 
Checking the Give priority to ends option is used to change the distribution mode of the repetition instances. This 
is necessary for the rest of the exercise (measured distance parameter). 
 

Do not give priority to ends Give priority to ends 

  
 
 

 Click on OK to confirm the distribution definition window. 

 Center the constrained blocks in relation to the calculated distribution.  
 

Modify the repetition template 

Note: The Linear constraint option repeats the constrained block. This means that a template of the repetition is 
hidden and some instances are displayed. 

 Use the Modify element function and select one of the repeated constrained 
blocks. 

 Select the Edit template option to hide the repetition instances and display the 

template.  

 From the Shapes context, use the Chamfer function to apply a chamfer with a 

length = 1mm to the bottom and top faces of the shelf.  

 Use the Edit > Repeat > Show repetition function, and then select the template of 
the shelf to display the repetition instances again and hide the template. 
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Define the shelves 

 Define the shelves: 

- Designation: Glass shelf 
- Reference: GL-SH 
- Material: glass > glass 
- Coating: No coating 

 Define the set: 

- Designation: Glass shelves component 
- Reference: GL-SH-CP 
- Main set: Sub-assembly 

Creating the processes 

Create the martyr parts 

 Set the level 2 current. 

 Create the martyr parts of the component by creating two automatic constrained 
blocks with a thickness = 19mm on the right-hand and left-hand sides of the 
driver block. Position the constrained blocks outside the driver block.  

 Switch off layer 0. 
 
 

Create the measured parameter 

Note: As the shelves are repeated in Advanced mode, the distance of the first shelf from the bottom 
automatically adjusts to the height and the number of elements. 
In order for the multi-drillings to automatically start from the first shelf, a measured parameter from the bottom 
of the component to the first shelf will be created. 

 Create a measured parameter.  

 Select Distance parameter.  

 Select the lower face of the martyr part as the first element. Use the Plane option to select only faces. 

 
 Then select the bottom face of the low shelf as the second element. 

 Name this parameter dps. 
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Make the multi-drillings 

 

 In the Wood context, start the Drilling function.  

 Select Define model to create a new drilling.  

 Create this drilling in Model = User mode, and then name this model Shelf support 5x12. 

 

 In the drilling definition window, select Hole in the left-hand list, and then move it to the right-hand list. Click 
on OK to confirm. 

 Set: 

- Hole: Blind 
- Diameter: 5mm 
- Depth: 12mm 
- Bottom angle: 0° 

 Confirm with OK to create the new drilling model. 

 Start the Multi-drillings function.  

 Set Propagation = Double and select the inner face of one of the martyr parts as the support face. 

 

 Select: 

- the bottom edge of the martyr part as the starting face or edge for the first 
propagation. 

- the top edge of the martyr part as the terminate face or edge for the first 
propagation. 

- the front edge of the martyr part as the starting face or edge for the second 
propagation. 

- the rear edge of the martyr part as the terminate face or edge for the second 
propagation. 

 
The distribution definition window opens. 

 Select the drilling model you just created as the element to propagate. 

 
 
 
 

 

The Multi-drillings function is used to propagate a drilling directly on a face in one or two directions. 
Before performing the multi-drillings, a drilling model should be created. 

Simple propagation     Double propagation 

 
 

 

Note 
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 Set for the first propagation (on the height of the component): 

- Distribution mode: Step 
- Step (p): 32mm 
- Distance to start: dps – 64 
- Optimize the number of elements 

 Set for the second propagation (in the depth of the component): 

- Distribution mode: Distance 
- Distance to start (d0): 50mm 
- Distance to terminate (d1): 50mm 
- Element number: 2 

 Validate these parameters with OK to perform the multi-drillings. 

 Similarly, perform the multi-drillings on the second martyr part. 

Define the multi-drillings as processes 

 Define the multi-drillings as component processes using Assembly > Define component > Define tools. 

- Name of tool element: tool1 
- Designation of the tool element: Multi-drillings 

 Save and close this component. 

Include the component 

 Open the file Interior design.top. 

 Include the Glass shelves component using Assembly > Include standard.  

 To insert a driver block component in the same cabinet as an already inserted driver block component, select 
Housing mode = Like a component. 

 Set Merge drivers = NO. 

 

Note: Merge drivers = YES is used to merge the driver blocks 
of the two components. It is then not possible to modify the 
second driver block without modifying the first one, and vice 
versa. 
 

 Select the door inserted in the left-hand cabinet as the 
reference component. 

 Select the front arrow of the generated driver block, and 

use the shift.  
 

 Set Shift = 50mm, and select OK to confirm. 

 

 Validate the driver block with OK and set the Number of 
shelves parameter. 

 Perform the component processes automatically using 
the Automatic option. 

 Save the document. 
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Supplement: Shelf propagation as driver 

 

 Edit the Glass shelves component. 

 Open the construction tree using Ctrl + ². 

 In the Main tab, right-click > Edit and select the repetition of the shelf. 
Note: Editing a repetition in the construction tree makes it easy to find and 
modify the repetition instances, the propagation, as well as the repetition 
template. 
 

 On the Propagation line, right-click > Define driver. 

 

 Set: 

- Name of driving element: so 
- Designation of the driving element: Shelves offsets 

  

 Open the interior design document. Delete the Glass shelves component, and then reinsert it. 

Note: The driver propagations are taken into account when inserting the component. If the driver propagation is 
declared after being inserted, the component must be deleted, and then repositioned to be taken into account. 

 Once the component has been reinserted, use Modify element and select one 
of the glass shelves.  

 The Offset instance option is used to offset the selected shelf. 

 

Note: It is possible to set a positive or negative value as offset. The positive offset 
will be done in the propagation direction and the negative offset in the opposite 
direction. 

 Save the document. 
  

 

The linear and circular propagations, as well as the TopSolid’Wood distributions can be defined as drivers. 
This allows the position of a repetition instance to be modified after the component inclusion. 
For example, this helps avoid a collision between a hinge and another element, or adjust the position of a 
shelf. 
 
 

 

Note 
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Exercise 8: Creating separation panel components 
The goal of this exercise is to make two components as driver blocks of 
vertical and horizontal separation panels assembled by dowels and cams. 
To create this type of component, a shelf component assembled with martyr 
parts should first be created. This component will then be included, and 
repeated in a driver block component.  

Concepts addressed: 

- The automatic assembly 

Creating the shelf component 

Create the parts 

 Create a new Design document. 

 Create the following three parameters in Unit type = Length: 

- Value = 500mm; Name: w; Designation: Width. 
- Value = 200mm; Name: d; Designation: Depth. 
- Value = 19mm; Name: th; Designation: Thickness. 

 

 Define these parameters as drivers. 

 Create the sketch shown opposite. 
The dimensions are constrained on X and Y. 

 Extrude this sketch to a height: th. 
 
 
 

 

 Then draw the sketch of the 
martyr parts as shown 
opposite. 

 
 
 
 
 
 

 Make layer 1 current, then extrude the martyr parts in Alignment = Centered, Generatrix sketch = Global and 
Result = One shape per profile to a height of 200mm. 
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 Create a panel on the shelf. 
Note: A panel can only be made on a defined part. So when a 
panel is made on a non-defined part, the part definition is 
automatically started. 
 

 Define the shelf: 

- Designation: Fixed shelf 
- Reference: FX-SH 
- Material: wood > particule board 
- Coating: paint > mat white paint 

 Validate the definition with OK and configure the panel: 

- Place an edge on the front face of the panel. 
- Use the codified edge EDG-TH-2-PVC-OAK. 

 

Save and define the component 

 Save the component in the training library: 

- Family: Cabinets 
- Type: Separation panel 
- New variant: Fixed unitary shelf 

 Define the set 

- Designation: Fixed shelf component 
- Reference: FX-SH-CP 
- Main set: Content 

 

Assembling the parts automatically 

Create the automatic assembly 

 

 From a Design document, open the options: Tools > Options. 

 Go to TopSolid’Wood Configuration > Automatic assembly. 

 Select Add rule to create a new automatic assembly. 

 Double-click on the Untitled line and name this automatic assembly: Dowels + Cams. 

 
 

 Add a Pin component to the automatic assembly. 

 Select Smooth pin and Code: 30 x 8, then validate with OK. 

The Smooth pin component is added to the automatic assembly. 

 Select the Dowels predefined propagation for this component. 

 Set Centered thickness. 
 

 

The Automatic assembly function is used to assemble several parts together automatically. This function 
associates one or more standard components with a predefined propagation per component. 
 
 

 

Note 
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 Then add an Eccentric component to the automatic assembly. 

 Select Wood eccentric assembly hinge and Code: th 19, then validate with OK. 

 Set the Cams predefined propagation to Centered thickness. 
 

 

 Validate the Options window. 

Assemble the parts 

 Start the Automatic assembly function.  
The martyr parts are not defined, so they must be selected manually. 

 Select the two martyr parts, as well as the shelf. Click on Stop to confirm the selection. 

 In the Automatic assembly window, select Rules > Dowels + Cams. 

 

 Reselect the parts manually in the graphical zone, and validate the window. 

 Select the front face of the shelf as the start face. 

 Click on Centred automatically to automatically center the assembly in the thickness. 

 Click on OK to confirm. 

Note: In the case of a closed assembly (a cabinet for example), selecting Outside face or Inside face allows you to 
set the position of the cam cases automatically. 

 
The assemblies are generated.  
The green arrow represents the positioning 
direction of the assemblies in the thickness. 
The red arrow represents the positioning 
direction of the assemblies in the depth. 
 
 
 
 

 Place the cam cases downwards. 

 Validate the positionings with OK to perform the machinings. 

 Save and close the file. 
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Creating the distributed separation panel components 

Create the vertical separation panel component 

 Create a new Design document. 

 Create a driver block: 

- Name: db 
- X length = 1200; Y length = 500; Z length = 800 
- Current coordinate system 
- Designation: Cabinet block 

 Create the following two parameters: 

- Unit type = No unit; Value = 2; Name: ns and Designation: Number of separation panels 
- Unit type = Length; Value = 19; Name: th and Designation: Panel thickness 

 Define these parameters as drivers. 
 
To position and distribute the separation panels, the distance between 
the separation panels must be calculated beforehand. 

 Create a new parameter: 

- Unit type: Length 
- Value = (db.x-(ns*th))/(ns+1) 
- Name: ds 
- Designation: Distance between separation panels 

 Save the component in the training library: 

- Family: Cabinets 
- Type: Separation panel 
- New variant: Distributed vertical separation panels 

Include the component 

 Include the Fixed unitary shelf component. 

 Select for the parameter Width = db.z/Z length of db. 

 

 Select for the parameter Depth = db.y/Y length of db. 

 

 Select for the parameter Thickness = th/Panel thickness. 

Note: The two parameters of the components have the same name; it is then possible to connect them 
automatically using the Automatic -> Panel thickness = 19.000mm option. 
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 Click in the document to release the component. 

 Apply two constraints of the shelf on the driver block: 

- Origin: Front edge of the shelf; Destination: Front face 
of the driver block 

- Origin: Lower edge of the shelf; Destination: Lower 
face of the driver block 

Note: These two constraints must be set to Type = Alignment. 

 
 

 Then apply a third constraint: 

- Origin: Left-hand face of the shelf 
- Destination: Left-hand face of the driver block 
- Type = Alignment  
- Distance = ds 

  

 Select Stop to stop placing constraints. 

 Select Propagation: Linear, Propagation direction: X+. 

 Then set Distance per instance = ds+th. 

  

 Finally, enter Total number = ns. 

 Click on Stop. 
 

 Define the set: 

- Designation: Vertical separation panel component 
- Reference: VERT-CP 
- Main set: Sub-assembly 

 Save and close the document. 
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Create the horizontal separation panel component 

Using the same method as for the vertical separation panels, create a Horizontal separation panels component. 

 In a new document, create a driver block. 

 Create the two driving parameters: Number of separation panels and Panel thickness. 

 Create the distance parameter between the separation panels: Value = (db.z-(ns*th))/(ns+1). 

 Include the Fixed unitary shelf component and set the parameters. 

 Apply the constraints of the shelf to the driver block. 

 Propagate the separation panel linearly. 

 Define the set: 

- Designation: Horizontal separation panel component 
- Reference: HORIZ-CP 
- Main set: Sub-assembly 

 Save this component in the training library: 

- Family: Cabinets 
- Type: Separation panel 
- New variant: Distributed horizontal separation panels 

 

Using the separation panels 

 Open the interior design file. 

 Insert the Distributed vertical separation 
panels standard component in the two 
bottom cabinets. 

 Set the number of separation panels to 2. 

 Perform the machinings using Automatic. 
 
 
 
 
 
 
 
 

 Then insert the Distributed horizontal 
separation panels component in the middle 
compartment of the right-hand cabinet, as 
well as in the left-hand and right-hand 
compartments of the left-hand cabinet. 

 Set the number of separation panels to 1. 

 Perform the machinings using the 
Automatic option. 
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Note: A Driver block component can also be inserted outside a cabinet or a closed housing. If an open volume 
forms a rectangular parallelepiped, you can insert a driver block component in it. 

 Insert the Distributed horizontal separation 
panels component. 

 Select the outer right-hand face of the 
upper-mid cabinet as the cabinet block to 
place the separation panels between the 
upper-mid and the upper left cabinets. 

 
 
 
 
 
 
 
 

 Set an offset = 50mm on the front plane 
arrow. 

 Set 2 separation panels, and then click OK to 
confirm. 

 Perform the machinings using the 
Automatic option. 

 Save the document.  
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Exercise 9: Making a coffee table 
The goal of this exercise is to make a coffee table 
using the constrained block and the automatic 
assembly. 
 
 
 
 

Creating the table 

Create the construction volume 

 Create the following three length parameters: 

- Value: 1000; Name: w; Designation: Table width 
- Value: 450; Name: h; Designation: Table height 
- Value: 19; Name: th; Designation: Panel thickness 
 

 Define these parameters as drivers. 

 Create a construction volume using the Block function: 

- X length = w 
- Y length = w 
- Z length = h 
- Alignment point: Origin of the absolute coordinate system 

 Apply a transparency of 7 to this block.  

Create a second construction volume 

Note: The goal is to create a second construction volume in order 
to make the base of the table. 

 Start a new sketch.  

 Create a rectangular contour: 

- Dimension the width and height of the contour to a 
nominal value = w/3. 

- Dimension this contour to a nominal value = 100mm from 
the bottom and the right-hand side of the construction 
volume.  

 End the sketch. 
 
 
 

 Extrude this sketch: 

- Set Offset from starting curve = -h/2. 
- Select the Z+ direction. 
- Set Height = h-10. 

 Apply a transparency of 4 to this block. 
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Create the parts 

 Set the material to wood> particule board and the coating to paint > mat white paint. 

 Make layer 1 current. 

 Create an automatic constrained block on the top face with a thickness = 10mm. 

 Position this constrained block inside the construction volume. 

 Create the four parts of the base as constrained blocks from 
the second construction volume as shown opposite: 

- Thickness = th 
- There are two covering sides and two covered sides. 

 Switch off layer 0. 

 Create the two other parts making up the base as constrained 
blocks: 

- Thickness = th 
- First shift = 100mm 
- Positioning shift = w/6  

 Make a chamfer with a length = 2mm on the top 
and bottom faces of the table top. 

 
 
 

Saving and defining the table 

Define the parts 

 Define the parts of the base: 

- Designation: Base 1-6 
- Reference: B1-6 

 Define the table top: 

- Designation: Glass table top 
- Reference: GT 
- Material: glass > glass 
- Coating: No coating 

 Define the set: 

- Designation: Rectangular coffee table 
- Reference: REC-CT 
- Main set: Sub-assembly 

Save in the library 

 Save this component in the library using Assembly > Define component > Edit/save template > Save 
standard template: 

- Standard: Training library 
- Family: Furniture 
- New type: Tables 
- New variant: Rectangular coffee table 
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Assembling the table 

 Start the Automatic assembly function.  

 Select Main assembly. 

Note: In the TopSolid’Wood selection windows, including the one for the automatic assembly, parts can be 
selected following different criteria. 

 Activate Select by criterions. 

 Check Material and select particule board in the dropdown list. Thus, all the parts that are made out of 
particule board are selected. 

 
 

 
 
 

 Click on OK to confirm the selection. 

 Select: 

- The lower edge of one of the selected parts as the start face 
- Centred automatically 
- Inside face 

 Using the green arrows, adjust the position of the cam cases as shown below, then validate with OK to place 
the hardware parts and perform the machining operations. 

 

 Save and close this file. 
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Inserting the table 

 Open the interior design file and insert this table on layer 15. 

 Place a constraint between the bottom of the table and the ground. 

 Press the Esc key to exit the function. 
 

Note: As long as a component is not fully constrained, it can be moved and/or rotated using the Edit > Move 
parents and Rotate parents functions. 

 Start the Edit > Move parents function. 

 Select the inserted table as the element to move. 

 Position the table in the interior design, then left-click to validate the positioning. 

 Start the Edit > Rotate parents function. 

 Select Mode = Auto. 

 Select the top face of the table as the element to rotate. 

 Rotate the table, then left-click to validate the positioning. 
 

 
 

 Start the Modify element function. 

 Select the rectangular coffee table. 

 Select Parameter and select the parameter Panel thickness in the dropdown list. 

 Set this parameter to the value: 30mm and confirm with OK. 
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Exercise 10: Creating an extruded component 
 

Creating the extruded component 

Create the coordinate systems 

 Create a new Design document by selecting Without template. 

 Make layer 1 current. 

 Create a new coordinate system using Tools > Coordinate system, 
and click any point to the right of the absolute coordinate system. 

 Then select Set as current. 
Note: To create an extruded component, it is necessary not to work 
on the absolute coordinate system, that's why a new coordinate 
system is created and set as current.  
 
 
 

 Start the Edit > Name function and name this new coordinate system fr1.  

 Leave the Designation field blank, and click on OK to confirm. 

  
 

 Switch off layer 0. 

 Create a length parameter with a value = 100mm, a name: l and a 
designation: Length. 

 Create a duplicated coordinate system using Tools > Coordinate 
system > Duplicate coordinate system. 

 Select fr1 as the coordinate system, and set a translation in the Z+ 
direction and a translation distance: l. 

 Name this coordinate system fr2. 

  
 
 

 

Creating an extruded component enables you to easily use linear components such as baseboards, angles or 
cover profiles. 
It will then be possible to place this component directly between two points or on a whole contour, and 
perform the cuts between the different extruded components automatically (mitre cuts, covering/covered 
cuts). 
 
 
 
 
 
 
 
 
 
An extruded component must be created according to the procedure described below. 
 

 

Note 
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Create the profile 

 Create two length parameters: 

- Value: 100; Name: h; Designation: Baseboard height 
- Value: 15; Nom: th; Designation: Baseboard thickness 

 Create the sketch for the baseboard as shown opposite:  

- The thickness and height dimensions are constrained in symmetry on the 
X and Y axes. 

- The three fillets have a radius of 3mm. 

 End the sketch. 
 
 
 
 
 
 
 
 
 
 

 Extrude the sketch, but instead of entering a height, 
select the duplicated coordinate system. 

 
Note: Here the fr2 coordinate system must be selected and 
not the origin point of the coordinate system. 
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Create the key points 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 Start the Tools > Points > Offset point function.  

 Select the point shown opposite as the origin point.  
Note: The key points must be on the plane of the fr1 coordinate system. 

 Select the Y- direction and enter a distance: h/4. 

 Position the dimension to finish creating the offset point. 

The creation function automatically returns to the beginning. 

 Select the offset point created previously as the origin point. 

 Select the X- direction and enter a distance: th. 

 Position the dimension. 
 

 Use Assembly > Define component > Define key points. 

 Select the left-hand offset point as the key point or key coordinate system 
to insert. 

 Enter: 

- Name: p1.  

- Designation: Bottom left point.  
 
Note: To be able to interchange two extruded components, the key points must 
have identical names. 
Here, the key point is named p1 for Point 1. 

 Then select the right-hand offset point. 

 Enter the name: p2 and the designation: Bottom right point.  
 

 
 

 

 

Note 

Creating several key points (shown in blue opposite) allows the 
extruded component to be positioned in different ways in relation 
to the selected path (shown in blue below). 
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Define the component 

 Define the part using the Wood > Define > Define part function: 

- Designation: Part 
- Material: wood > beech 
- Coating: paint > mat grey paint 

 In the Cutting-up tab, click on the Invert axis button to obtain the length axis on the extruded component 

length.  

 

 Define the set using the Wood > Define > Define set function: 

- Designation: Baseboard type 1 
- Reference: BS-1 
- Main set: Single unit 

 Save the component in the library using Assembly > Define component > Edit/save template > Save standard 
template: 

- Standard: Training library 
- New family: Profiles 
- New type: Baseboards 
- New variant: Type 1 

 
Note: In order to be used as an extruded component and automatically perform the cuts, this component must 
be defined as an extruded component. 

 Start the Assembly > Define component > Define extruded component function. 

 Select All assembly to define all the parts of the assembly as extruded parts. 

  

  Save and close the file. 
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Using the extruded component 

Draw the contour 

 Open the interior design file. 

 Make layer 16 current. 

 Start a new sketch. 

 Using the Contour function, draw a contour enclosing the cabinets on the left side, the front side, as well as 
the right side as shown below. 

 

 Start the Create offset profile function in Offset type = Profile mode to draw the offset of the curve to a 
distance = 50mm. 

  
 

 
Note: The offset curve must be inside the reference curve.  
To do this, when prompted to enter the distance, place the offset inside using the mouse, enter 50 (by default in 
the Through point box), then press Enter to confirm. 

 End the sketch. 

Insert the extruded component 

 In the Wood context, start the Extruded component function.  

 In the Standard component inclusion window, select the Training library library and select the component 
Profiles > Baseboards > Type 1. 

 
Note: By default, an extruded component is positioned between two points to generate. Once the extruded 
components have been generated, cuts can be performed between the extruded components using the Assembly 
> Use process function. 
The On curves option is used to automatically generate all the extruded components on a contour, and then 
perform the cuts automatically. 

 Select the On curves option.  

 Select the offset sketch in Curves. 

The three extruded components are then generated. 
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Different parameters can then be configured: 

- Key point: Used to choose the key point to position the extruded components. 
- Rotation angle: Used to rotate the extruded components. 
- Cut: Used to choose the type of cut to be applied to the components. 

 Set: 

- Key point: Bottom right point 
- Rotation angle: 0° 
- Cut = Mitre cut 

  

 Click on OK to confirm. 
 
Note: As the counter is included on a path, the direction of the extruded components may be reversed. To modify 
the direction of a sketch, use the Curves > Origin function, select the sketch, invert the direction of the red arrow, 
then reinsert the extruded components. 

Supplement: Creating a catalog and adding baseboards 

Create the catalog 

 Delete the baseboards inserted in the interior design document, and then close this document. 

 Edit the template document of the baseboard: Assembly > Define component > Edit/save template > Edit 
standard template. 

 Generate the catalog: Assembly > Define component > Edit catalog header. 

 Select All parameters and texts in the dropdown list. 

  
 
The catalog is then generated in Excel format.  

 As the parameter l is used to define the extruded component, delete 
the column l in the Excel catalog. 

 Fill in the catalog boxes as shown opposite. 
 

 Reopen the interior design document. 

 Reinsert the extruded components on the sketch by selecting the code: 
100x15 when selecting the standard extruded component. 

Add detailing baseboards 

 Start a new sketch. 

 Draw a contour on the wall around the part, as shown below. 

 

 End the sketch. 

 Using the Wood > Extruded component function, insert the baseboard with the code: 80x10. 

 Select On curves and select the previous sketch. 
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 Set: 

- Key point: Bottom left point 
- Rotation angle: 0° 
- Cut = Mitre cut 

 Click on OK to confirm. 

 Start the Assembly > Use process function. 

 Select the left-hand baseboard of the cabinets as the component to use. 

 

 Select Main cut.  

 Set Offset: 0mm, Hide tools = NO and select the baseboard on the wall as the tool shape to use. 

  

 The arrow must show the side of the baseboard to delete. Click on the arrow to invert. 

 Confirm with OK to perform the cut. 

 Repeat the operation to cut the right-hand baseboard of the cabinets. 
 

 
 

 Save the document. 
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Exercise 11: Creating a draft template 
 

 

 

 

Creating a draft template 

Create the file 

 Create a new Draft document.  

 Select Without template and select Paper format: A4H in the 
dropdown list. 

 If necessary, delete the document’s title block.  

 Using the Modify element function, modify the draft and uncheck 
the Center mark, Orientation mark, Coordinate system and 

Graduations boxes.  
 
 
Note: In order to be available when creating a new document, the template document must be saved in the 
template folder of the Config or Group folder. 
The Config folder corresponds to the individual configuration of the user station, while the Group folder 
corresponds to the common configuration of the different stations of the company. 
 

 Save the file in the folder C:\Missler\Group\Template. 

 Rename this file Training draft A4H. 
 

Create a title block 

 Use the Detailing > Title block function. 

 Set Width: 110mm and Height: 35mm. 

 Select Hook on border. 

 
 
It is then possible to create cells for the title block. 

 Select Cutting type = Regular cut in the dropdown list. 

 Set Number of rows = 4 and Number of columns = 1. 

 

 Click on OK to confirm and click inside the title block to cut it. 

 Reselect Cutting type = Regular cut in the dropdown list. 

 Set Number of rows = 1 and Number of columns = 3, then click on OK to confirm. 

 In Cell to cut, select the second row from the bottom. 
 
 
 

 

In TopSolid, documents can be saved as templates. 
A new document can be created from this template, and then saved, regardless of the original 
template. 
Creating draft templates allows you to preconfigure drafts with for example a specific title block, the 
company logo, display settings… 

Note 
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 Select Cutting type = Vertical cut, and then cut the first and the third rows from the bottom as shown below. 

 
 
Note: To align a cutting line with an existing line, simply click the end point of the existing line. 
 

Insert text in the title block 

 Start the Insert function.  

 Select the title block as the element near insertion place. 

 Select the left-hand cell of the third row from the bottom to insert an element in. 

 In the cell, enter Element to insert or text to create: Draft name. 

 

 Press Enter to validate, then select Fast choice > Center center to center the 
text on the width and height of the cell. 

 Validate with OK to position the text. 

Note: Inserting a plain text will make it possible to quickly modify this text when drafting to enter the draft name. 

 

 Then select the right-hand cell of the same row. 

 Select Scaling factor in the dropdown list.  

Note: This dropdown list contains variables that are automatically updated when using the draft document. 

 Set Fast choice > Center center and validate with OK. 

 Similarly, insert the following on the second row from the bottom: 

- Left-hand cell: Creation date 
- Middle cell: Author 
- Right-hand cell: Folio number (i/n) 

 Then insert the variable Property > Designation in the first row. 

 Validate with OK and select No element. 
 
Note: Inserting a variable using the No element option allows the variable to be inserted according to the drafted 
element. The designation of the drafted element will be then automatically displayed here. 
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 In the left-hand cell of the first row from the bottom, insert the name of your company. 

 Then click in the right-hand cell and select the Bitmap option.  

Note: The Bitmap option is used to insert an image in the title block. 

 Select the company logo you saved on your computer or the provided file TopSolid’Wood.jpg. 

 Uncheck the Linked to the bitmap file option and select Position in 
cell > Center center. 

 
Note: By unchecking the Linked to the bitmap file option, the image of the title block is not associated with the 
image file in Windows. This option is necessary if the draft template is used on different stations on the network 
or if the image is then deleted or moved. 

 To avoid distorting the logo, uncheck Resize with distortion. 

 Validate with OK to insert the image. 

 

Configure the draft template 

 Open the document properties.  

 In Projection parameters, check Use realistic rendering. 

 Save and close this file. 
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Using the draft template 

Create a trimming volume 

 
 
 
 
 

 Open the interior design file.  

 Make layer 17 current and start a new sketch. 

 Using the rectangular contour, draw a rectangle that encloses the interior design as shown below. 

 

 End the sketch, then extrude it with an offset from starting curve = -100mm and to a height = 2600mm. 

 Apply a transparency of 10 to this block. 

 Start the Tools > Draft trimming volume function. 

 

 Select the extruded volume as the trimming volume for views. 

 Name this volume tv and click on OK to confirm. 

 

 Save the file. 

Create the draft and the main views 

 Create a new Draft document. 

 In the advanced parameters, select the Training draft A4H draft template in the 
group templates. 

 Click on OK to confirm.  

Note: A new draft file is then generated from the template. 

 Create a main view.  

 Select Assembly. 

 Select Document containing the set = Interior design in the dropdown list. 

 

When making a draft, it is possible to create a trimming volume. This allows you, when only a 
portion of the Design file has to be drafted, to trim the view by a block drawn beforehand. 

Note 
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 Adjust the view as shown opposite using the green arrows.  

 Check Shading view. 

 Set the smooth edges and the hidden lines to Hidden. 

 
Note: The setting of the smooth edges corresponds to the visualization of the edges 
between the tangent faces. 
The hidden lines are the non-visible edges in the projected view. Here, the hidden 
lines are hidden to avoid overloading the view. 
 
 

 At the bottom right of the window, select Trimming volume > Volume: 
tv in the dropdown list 

 Confirm the window with OK to calculate the view. 

 Place the view and set the scaling factor relative to drawing to 0.02. 

 To regenerate the view, select the Regenerate function and select the view.  

 Use Move parents to position the view as shown below.  
 

Note: For now, only the elements that make up the assembly have been drafted. Since the walls and the ground 
are not included in the assembly, they have not been drafted. To view them, add them manually in the view. 

 Select Window > Tile vertically. 

 Start the Insert function.  

 Select the main view in Element near insertion place. 

 To select several elements, use the selection lasso.  

 In the 3D document select the walls, the ground and the columns, then validate the selection with OK. 

 Regenerate the view. 

 

 Create the full section view as follows:  

- Alignment = No 
- Set the section view upright = No 
- Hidden lines = Hidden 
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 Modify the section view to check the Shading view option. 

 

 Save this draft document in the Interior design folder and keep the default name. 

 Use Modify element to modify the text of the title block: Draft name. 

 In Text, enter Assembly main views. 

 

Create a new drawing 

Note: It is possible to create several drawings in one document. Each drawing is called folio. 

 Use Tools > Drawing.  

 Select the existing drawing as the drawing to copy. 

 Click on OK to confirm the parameter window of the new drawing without changing anything. 

 Set Hook point = Bottom-Left and select the bottom right point of the first drawing in New position for the 
drawing. 

 

 Select the title block of the first drawing in Title blocks and tables to copy. 

 Click on Stop to finish the copy.  
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Create a perspective view 

 Open the Design file of the interior design. 

 Make layer 15 current and switch off layer 17. 

 Open the View tab , and then select Visit mode.  
Note: In an interior design, the visit mode is used to visit the fitted-out room(s). Like a FPS video game, the mouse 
is used to rotate the view and the keyboard arrows allow you to move in the drawing. 
 

 Select any point in the room in Position of the user. 

 Select a point on the cabinets as the target point. 

The visit mode starts. 

 Using the keyboard arrows and the mouse, configure the same view as shown below. 

 Press Esc on the keyboard to stop the visit mode. 

 

Note: To go back to the perspective view, open the View tab  and select Perspective view.  

 Select Window > Tile vertically. 

 Click in the draft document to make it current. 

 Create a main view.  

 Select the copied left-hand drawing as the drawing in which to work. 

 Select Assembly, then select Document containing the set = Interior design in the dropdown list. 

 Set the smooth edges and the hidden lines to Hidden. 

 Select Trimming volume: tv. 

 Click in the 3D or 3D coordinate system or face field, and then click in the space of the Design document to 
generate the drawing view as the 3D. 

 Validate with OK and position the view. 

 Using Modify element, modify the drawing. 

 Set the scaling factor to 0.03. 

 Validate with OK and regenerate the view. 
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 Use Move parents to position the view as shown below.  

 Modify the text Assembly main views to Perspective view. 
 

  
 

 Using the Insert function, it is possible to add the walls and the columns of the design document in the 

perspective view.  
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Exercise 12: Creating a BOM template 
 

 

 

Creating a BOM template 

 In a Draft document, start the Bill of materials > Edit bill of material file function.  

Note: This function can also be found in a Design document in Tools > Edit bill of material file. 
Three tabs are available: 

- Standard: Contains the TopSolid default BOM templates. 
- User and Group: Contain the User and Group BOM templates. 

 Click on the Group tab. 

 Select Create new bom file. 

 In Name of new bom file enter General part BOM.  

 Click on OK to confirm. 

Note: The Creation or modification of bom file window opens. Each row corresponds to a different column of 
BOM information. 

 Double-click in the Definition box on the first row to insert information. 

 In the modification window, select Defined functions > Index in the dropdown list. 

Note: The BOM functions are not alphabetically ordered.  
To find the Index function more easily, press the ‘i’ key several times in order to scroll through the functions 
starting with ‘i’. 

 

 Click on OK to confirm. 

 Repeat the operation to add the Designation and Reference functions. 

 

 Then insert the Count function. Before validating the function, change the title to QUANTITY and check the 
box Make sum on this column to obtain the right quantity. 

 

 Insert the Material and Coating functions. 
 

 

A BOM template is used to create bills of materials in a draft document, but also to export projects 
to Excel for example. 
Creating a template allows all relevant information to be displayed in the BOM. 

Note 
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 Insert the Part length function. 

Note: By default, dimensions are in meters. The function format must be changed. 

 In the Format field, enter 01|mm. 

- 01 corresponds to the desired number of decimal places. 
- To make the | symbol, press Alt Gr + 6. 
- mm displays the dimensions in millimeters. 

 

 Validate the function and insert the Part width and Part thickness functions in the same way. 

 Then insert the Four edges or laminates function. 

 Change the title of this function to 4_PART_EDGES. 

Note: The Four edges or laminates function allows the four edges placed on a part to be displayed on the same 
column. 

 Finally, insert the Reference function again: 

- Modify the title of this function to BAR CODE. 
- Select Bar code > 128 in the list to display this column as follows: Bar code 128. 

 Click on OK to validate the BOM template. 
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Using the BOM template 

Create a new drawing 

 Open the Design document Interior design.top, then the Draft document Interior design.dft. 

 In the draft, Start the Tools > Drawing function and select a drawing of the document. 

 In the drawing modification window, select Paper format > A3V.  

 Using the hook point Bottom-Left, position this drawing to the right of the second drawing, and exit the 
function by pressing the Esc key. 

 

Create the BOM 

 Open the Bill of Material context.  

 Start the Bill of material function.  

 In the Group tab, select the General parts BOM template, and then click on OK to confirm. 

 

 Select the A3V drawing as the drawing in which to work. 

 Select Assembly to include all the elements of an assembly in the BOM.  

 Select Document containing the set = Interior design in the dropdown list. 
 

Note: A BOM can be displayed according to three depths: 

- At top level: The sets of the first level are displayed. 
- Flat BOM: The elements of the lowest levels are displayed. 
- Multi level: The sets can be unfolded in order to display the component elements. 

 Set: 

- Depth = Multi level. 
- Add a line for set = No. 
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Note: A bill of material can be placed over a title block or between two points. 

 In Position of bill of material or title block, select the bottom left point of the A3V drawing’s frame, then the 
bottom right point as the second alignment point. 

 Exit the function by pressing the Esc key. 

Unfold the BOM 

 Start the Modify element function.   

 Select the bill of material. 

 Go to the Bill of material level choice tab. 
 
Note: This tab is used to modify the depth of the bill of material. In multi-level depth, the sets can be unfolded to 
display the component parts. 

 Using the + icon, unfold the Vertical separation panel component set, then the Glass panel door and Wall 
shelf sets, and then the Free-running sided cabinet set. 

 Validate the window with OK to calculate the desired BOM. 

Index elements 

 In the Bill of material context, start the Index function.  

 Set Search for 3d part: YES, One Text, Name = 1. 

  
 
Note: Search for 3d part: YES is used to index 3D file elements. 
One text displays the part index only. 
Name = 1 is used to set the created index number. The next indexes will be incremented, based on this value. 
>>: Use the advanced parameters to define the type of positioning of the balloon, as well as its style. 
 

 In Element to index, select an element in one of the three drawing views. 

The index is created. 

 Place the index on the drawing, then click to validate. 
 
Note: As the bill of material is in multi-level, it is possible to index two different BOM elements with the same 
selection.  
For example, in the case of a free-running sided cabinet:  

- In Bill of material the Free-running sided cabinet set, as well as the Top panel are displayed. 
- When selecting the element to index, if selecting the top, it is possible to index either the free-running 

sided cabinet, or the top. 
- The Bill of material level choice opens and the element to be indexed is required. 
- Select the element to be indexed and click on OK to confirm the window. 
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Exercise 13: Creating a multi-draft 
 
 
 
 
 
 
 
 
 
 
 
 

Creating the multi-draft template 

Create the template 

Note: To create a multi-draft, a specific draft template should be created. Here, the template will be created from 
the draft template previously created. 

 Open the file Training draft A4H from the folder C:\Missler\Group\Template. 

 Use File > Save as, and then save this file in the folder C:\Missler\Group\Template by renaming it Multi-draft 
A5H. 

 Modify the draft frame using Modify element.  

 Select Paper format > Not standard in the dropdown list. 

 Then set: 

- Width: 210mm 
- Height: 148.5mm 
- Name: A5H  

 Click on OK to confirm. 

Create the views 

 In the Wood context , start the Multi-draft function.  

 Select Create template, and then Create view. 

 >  
 
Note: Create view is used to position a view of the part or the assembly which will be drafted. 
Three types of views are available: 

- 2D view: It is the view configured from the part definition’s Drawing tab. By default, it is oriented like the 
sawing up coordinate system. 

- First machining/second machining: These views are configured from the First positioning and Second 
positioning tabs of the part definition’s Machining tab. By default these views are identical to the sawing 
up coordinate system, and can be used to generate draft documents for machining. 

 Select View: 2D in the dropdown list and click on OK to confirm. 

 Keep the default scaling factor to 1, and then position the view on the left-hand side of the drawing. 

 Then click on Auxiliary view and position a side view on the right-hand side of the drawing. 
 

 

Creating a multi-draft automatically generates, from a specific template, the draft of several parts 
and/or assemblies by dimensioning them and including information in the title block automatically. 

   

Note 
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Note: The view frames may go beyond the title 
block or the draft frame. This does not matter 
since the views are automatically scaled and 
recentered on the drawing when generating the 
multi-draft. 

 
 
 
 
 

 
 
 

Set the template 

 Open the document properties.  

 Go to TopSolid’Wood properties > Draft to set the multi-draft. 

 In Elements to dimension, tick: 

- Dimension drawings to dimension the part views. 
- Part dimensions to dimension the part dimensions. 
- Edge dimensions to place notes on the part’s edges. 
- Codification to note the edge codifications on the part. 

 Uncheck all the other boxes. 
 
Note: To calculate the scale factor, two options are available: 

- Free scale factor: The draft scale factor is calculated as accurately as possible, according to the clutter in 
the view, the title block and the dimensions. However, this mode can generate non-conventional scale 
factors (for example 0.127). 

- Scale factor chosen in the list: The scale factor is first calculated as accurately as possible, but the scale 
factor used is the nearest lower one in the list. 

 Select Scale factor chosen in the list. 

 Click on Add to insert the new scale factors of 0.05 and 0.15. 

 Validate the window with OK. 

 Use the Delete element function to delete the text Draft name. 

 Start the Insert function.  

 Select the title block, and then the box in which the text has been deleted. 

 In the dropdown list, select Property, then Reference. Click on OK to confirm. 

 Select No element. 

 In the positioning window, select Center center, then click on OK to confirm. 

 Save and close this document. 
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Making the multi-draft 

 Open the design document Interior design. 

 In the Wood context, select the Multi-draft function.  

 Set Depth: Multi level in order to view all the parts of the assemblies. 
 

Note: When creating the multi-draft, it is possible to put on a paper format 
two drafts in lower format. 
For example, as the draft template created is a horizontal A5 format, two 
drafts can be placed on a vertical A4 paper format. 
 
 
 
 
 

 Set Put together all drafts in one document = YES and select Paper format = A4V. 

 

 Click in the graphical zone to choose this file. 

 Select User templates > Multi-draft A5H in the list. 
 
All parts made of particule board will be drafted. 

 Tick the Material box and select Particule board in the dropdown list. 

 

 Confirm the selection with OK. 

All the parts are then automatically drafted. 

 Save this file in the folder Interior design and rename it Draft of the 
parts. 

 
 
 
 
 
 
 

Place the axes automatically 

In a Draft document, it is possible to place the axes of all the drafted circles automatically. 

 In the View context, start the Axes function.  

 Select Projected axis, All views, Automatic and OK. 

 >  >  >  

Note: The All views option is used to place the axes on all the document’s views and the Automatic option is used 
to place the axes on all the document’s cylinders. 
It is also possible to define a minimum radius and a maximum radius so that the axes are not placed on certain 
cylinders. 
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Note: The part drafts of a multi-draft behave in the same way as a simple draft. This makes it possible to modify, 
move and dimension the views, or modify the drawings. 
 

Supplement: Inserting information on the part in the title block 

 Open the multi-draft template Multi-draft A5H in the folder C:\Missler\Group\Template. 

 Delete the existing title block. 

 Recreate a title block using the Detailing > Title block function. 

 Enter Width: 190mm and Height: 30mm. Select Hook on border to position the title block. 

 Perform a vertical cut at about 35mm from the right-hand segment. 

 Perform: 

- A regular cut on a column and three rows of the two cells so as to obtain the following result: 

 

- A regular cut of a row and two columns on the top left row. 
- A regular cut of a row and three columns on the two bottom left rows. 

 

 Using the Insert function, insert the following in the three left-hand cells: 

- the logo 
- the folio number (i/n) 
- the scaling factor 

 
Note: To insert additional variables in a title block, first create a bill of material in order to retrieve the 
information in the title block. 

 In the Wood context, start the Multi-draft function. 
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 Select Create template, and then Create bill of material. 

 In the Group tab, select the General part BOM template, and then click on OK to confirm. 

 Click any two points to the left of the template to place the BOM. 

 Click on OK to confirm. 

 In order for the BOM not to be displayed during the multi-draft, use the Mode/Visibility function and select 

the title block and the two points you just clicked to hide them.  

 Start the Insert function.  

 Select the title block, and then the upper left-hand cell. 

 Select BOM property in the dropdown list.   

The different columns of the BOM are available. 

 Select Designation.   

 Select No element.  

 Set Fast choice > Center center to center the text in the cell, and then click on OK to confirm. 

 Select the other cells to insert the information below: 

  
 

Note: As there is no information to be displayed at the moment, the variables are shown as – (dash). 
 
In order to make the reading easier, it is possible to add text with the variables. 

 Using the Modify element function, modify the Part_length variable (lower left-hand cell). 

Note: The variable is displayed between the symbols < and > as follows: 
<text_displaying_bill_of_material_information_n> 

 Insert Length = before the variable.  
Length = <text_displaying_bill_of_material_information_6> 

The text Length = will be displayed before the variable. 
 

 Repeat the operation in order to obtain the following title block: 

  

 Open the document properties.  

 Open the Table/Bill of material > Bill of material section. 

 Check Automatic update of bills of material, and then click on OK to confirm. 

 Save and close this file. 

 Open the file Interior design.top. 

 Restart the multi-draft by following the same procedure described on page 109. 
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The information relative to the parts are then automatically included in the title block. 
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Exercise 14: Configuring the project 
 
 
 
 
 
 
 
 
 
 
 
 

 
 Open the project Interior design.top. 

 In the Wood context, start the Matters configurator function.  

Note: There are four types of configurations: 

- Matter configuration : Used to modify the part matters. 

- Edge configuration : Used to modify the panel edges. 

- Laminate configuration : Used to modify the panel laminates. 

- Property configuration : Used to modify the part properties (Designation, Reference, Part type…). 
 
Edges and laminates can be configured in the assembly only if they have been made modifiable in the assembly 
via this same configurator from the template document. 

 Select Main assembly to take into account all the parts of the assembly in the configurator. 

 
 
The configuration window opens. The top part of the window is used to set the type of part selection. Three 
modes are available: 

- Select manually: The parts to configure can be selected directly from the graphical zone or from the list of 
parts with a right-click > Select. 

- Select parts by material: The selection by material includes all the parts with the same matter and 
thickness. 

- Select by criterions: This selection is used to select parts according to one or several criteria, among those 
proposed by the software (Type, Material, Coating, Thickness and Property). 

 Activate the Select by criterions mode. 

 Check Material and select oak in the dropdown list. 

 In the Material tab, select wood > walnut. 

 Click on Apply matter to apply the chosen material to 
the selected parts.  

 
  

 

Once a project is complete, some functions allow you to configure it. 
For example, you can modify the part material or the panel edges without modifying the library 
template. The configured elements are then specific to that project. 
 

   
 

   

Note 
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 Select Material > particule board in the dropdown list. 

 In the Coating tab, select wood > oak. 
 
 
 
 
 

 Click on Apply coating to apply the chosen coating to the selected parts.  

 

 Keep checked Material > particule board. 

 Check Thickness > 8mm. 
 

 In the Coating tab, select paint > mat white paint. 

 Apply the coating using the Apply coating button. 

 Uncheck Material and Thickness. 

 Check the Property option and set Designation > Fixed shelf. 

 Apply the coating: paint > mat white paint. 
 

 Activate the Select manually mode. 

 In the graphical zone select the bent front, the top, as well as the baseboards of the counter. 

  

 Apply the coating: paint > mat white paint. 

 Click on OK to validate the window. 

 Save the file. 
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(To be completed and returned to the training instructor at the end of the course) 

TopSolid’Wood - Advanced 
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By completing this individual evaluation form, you are helping to improve the quality and usefulness of the training provided in the future. Please complete it 
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What grade would you assign?  
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Orientation (quality, organization, user-friendliness, etc.) □ □ □ □ 
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Instructor's teaching method □ □ □ □ 
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 DURATION  No Not really Quite Yes 
Does the overall duration of the course seem appropriate? □ □ □ □ 
If no, was it? Too short □ Too long □ 
 
 PACE   No Not really Quite Yes 
Does the overall pace of the course seem appropriate? □ □ □ □ 
If no, was it? Too slow □ Too fast □ 
 
 USE OF ACQUIRED KNOWLEDGE IN THIS TRAINING  No Somewhat no Somewhat yes Yes 
Have you found this training to be useful in your work? □ □ □ □ 
Do you think you can put the acquired knowledge into use quickly? □ □ □ □ 
Do you believe that you have achieved your objectives  

upon completion of this course? □ □ □ □ 
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